Closed Bug 930393 Opened 6 years ago Closed 6 years ago

--disable-accessibility breaks build in nsBaseWidget.cpp(1517) : error C2027: use of undefined type 'nsIDocument'

Categories

(Core :: Widget, defect, blocker)

defect
Not set
blocker

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: WeirdAl, Assigned: WeirdAl)

Details

Attachments

(2 files)

Attached file fx-opt.mozconfig
This has to have been a recent regression.  I disable accessibility because I build with Visual Studio Express editions.
Assignee: nobody → ajvincent
Status: NEW → ASSIGNED
Attachment #821506 - Flags: review?(roc)
I hit this as well (on linux), since I have --disable-accessibility in one of my build configurations.

I went ahead and pushed this for WeirdAl (with a slightly-clarified commit message), to minimize the number of other folks who get bitten by this:
 https://hg.mozilla.org/integration/mozilla-inbound/rev/c89628d36c8d
Flags: in-testsuite-
OS: Windows 7 → All
Hardware: x86_64 → All
Component: Build Config → Widget
Thanks, Daniel - I would've asked for checkin-needed next. :)
No problem; thanks for the quick bug report & patch!
:WeirdAl patch also worked for me on Mac OS x 10.9. Error reported by clang was different though: a forward declaration on line 1516 file nsBaseWidget.cpp.

Thank you.
Sorry. It was line 1517.
https://hg.mozilla.org/mozilla-central/rev/c89628d36c8d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.