Closed Bug 930495 Opened 6 years ago Closed 6 years ago

Intermittent OSX DOM Level Crashes |test_namedNoIndexed.html | test_nodeattributenodevalue.html |test_getAttributeNS01.html | application crashed [@ libSystem.B.dylib + 0x39d6d]

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 928222

People

(Reporter: cbook, Unassigned)

References

()

Details

Rev4 MacOSX Snow Leopard 10.6 fx-team opt test mochitest-2 on 2013-10-24 03:16:58 PDT for push b50aa73e2a16

slave: talos-r4-snow-080

TEST-UNEXPECTED-FAIL | /tests/dom/bindings/test/test_namedNoIndexed.html | application terminated with exit code 256

PROCESS-CRASH | /tests/dom/bindings/test/test_namedNoIndexed.html | application crashed [@ libSystem.B.dylib + 0x39d6d]
Return code: 256

and 

TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/dom-level1-core/test_nodeattributenodevalue.html | application terminated with exit code 256
PROCESS-CRASH | /tests/dom/tests/mochitest/dom-level1-core/test_nodeattributenodevalue.html | application crashed [@ libSystem.B.dylib + 0x39d6d]
Return code: 256

https://tbpl.mozilla.org/php/getParsedLog.php?id=29589741&tree=Fx-Team
Summary: Intermittent OSX DOM Level Crashes |test_namedNoIndexed.html | test_nodeattributenodevalue.html | | application crashed [@ libSystem.B.dylib + 0x39d6d] → Intermittent OSX DOM Level Crashes |test_namedNoIndexed.html | test_nodeattributenodevalue.html |test_getAttributeNS01.html | application crashed [@ libSystem.B.dylib + 0x39d6d]
This backout will change the stack, if not fix this:
http://hg.mozilla.org/mozilla-central/rev/5a9ac6fed6ff
(In reply to Karl Tomlinson (:karlt) from comment #15)
> This backout will change the stack, if not fix this:
> http://hg.mozilla.org/mozilla-central/rev/5a9ac6fed6ff

Seems to have done the trick :-)
https://tbpl.mozilla.org/?rev=5a9ac6fed6ff
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928222
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.