Closed Bug 930511 Opened 6 years ago Closed 6 years ago

Firefox OS Simulators launch error in OS X Mavericks

Categories

(Firefox OS Graveyard :: Emulator, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 928168

People

(Reporter: aaroncajes, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

1.) Open Firefox
2.) Open Firefox OS Simulator in the Web Dev selection
3.) Press (Stopped) button to open the Simulator


Actual results:

I'm getting an error when launching the Firefox OS simulator


Expected results:

It should display the Firefox OS simulator without any errors occuring.
It seems that this bug only occurs when trying to launch the simulator, i've tried to push an app on an actual device and it worked without any exceptions.
Here is a workaround: if you run Firefox from the DMG file without installing it, you'll be able to run the simulator, and push to a phone without any problem. Even if you already have a installed version on your computer, it will work: it will just use your actual default profile.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928168
The 1.2 simulator seems to launch fine from the App manager in Firefox 26 ( soon to be in Beta ) - is this also an acceptable workaround?
I'm able to run 1.3 simulator via about:app-manager on Fx 26 also.
You need to log in before you can comment on or make changes to this bug.