Last Comment Bug 930511 - Firefox OS Simulators launch error in OS X Mavericks
: Firefox OS Simulators launch error in OS X Mavericks
Status: RESOLVED DUPLICATE of bug 928168
:
Product: Firefox OS
Classification: Client Software
Component: Emulator (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 06:32 PDT by Aaron Cajes
Modified: 2013-12-04 22:57 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen Shot 2013-10-24 at 9.26.00 PM.png (214.60 KB, image/png)
2013-10-24 06:32 PDT, Aaron Cajes
no flags Details

Description Aaron Cajes 2013-10-24 06:32:40 PDT
Created attachment 821670 [details]
Screen Shot 2013-10-24 at 9.26.00 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

1.) Open Firefox
2.) Open Firefox OS Simulator in the Web Dev selection
3.) Press (Stopped) button to open the Simulator


Actual results:

I'm getting an error when launching the Firefox OS simulator


Expected results:

It should display the Firefox OS simulator without any errors occuring.
Comment 1 Aaron Cajes 2013-10-24 06:35:21 PDT
It seems that this bug only occurs when trying to launch the simulator, i've tried to push an app on an actual device and it worked without any exceptions.
Comment 2 Frédéric Harper 2013-10-26 11:34:53 PDT
Here is a workaround: if you run Firefox from the DMG file without installing it, you'll be able to run the simulator, and push to a phone without any problem. Even if you already have a installed version on your computer, it will work: it will just use your actual default profile.
Comment 3 Myk Melez [:myk] [@mykmelez] 2013-10-28 13:21:09 PDT

*** This bug has been marked as a duplicate of bug 928168 ***
Comment 4 Jeff Griffiths (:canuckistani) (:⚡︎) 2013-10-29 09:30:29 PDT
The 1.2 simulator seems to launch fine from the App manager in Firefox 26 ( soon to be in Beta ) - is this also an acceptable workaround?
Comment 5 Edwin Wong [:edwong] 2013-11-13 13:57:18 PST
I'm able to run 1.3 simulator via about:app-manager on Fx 26 also.

Note You need to log in before you can comment on or make changes to this bug.