custom field is not mandatory but generates "not allowed to be null" error when saving bug report

RESOLVED DUPLICATE of bug 919475

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED DUPLICATE of bug 919475
4 years ago
4 years ago

People

(Reporter: S. Snavely, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; Tablet PC 2.0)

Steps to reproduce:

1) Added a bug with the custom field showing and blank for just a subset of products and then saved the bug.
2) Added a bug with the custom field showing but left blank for all products and then saved the bug.
3) Added a bug with the custom field showing but left blank for all products with bugmail off and then saved the bug.  


Actual results:

I received an Oracle DB error saying that the custom fiedl was not allowed to be null.


Expected results:

The bug should've saved with no error since the custom field was not required.
(Reporter)

Updated

4 years ago
Severity: normal → major
Priority: -- → P1

Updated

4 years ago
Priority: P1 → --
Summary: custom field is not mandatory but generates not allowed to be null error on the save of a bug → custom field is not mandatory but generates "not allowed to be null" error when saving bug report

Comment 1

4 years ago
You are using Bugzilla 4.2.2. This bug has been fixed in Bugzilla 4.2.7.
Assignee: general → create-and-change
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Bugzilla-General → Creating/Changing Bugs
Resolution: --- → DUPLICATE
Duplicate of bug: 919475
You need to log in before you can comment on or make changes to this bug.