bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[ABS POS]{ib} Absolute placement broken when container is empty

RESOLVED DUPLICATE of bug 79315

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 79315
17 years ago
5 years ago

People

(Reporter: mozilla3eran, Unassigned)

Tracking

({css2, testcase})

Trunk
mozilla1.1alpha
x86
All
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
An absolutely positioned element whose container is an empty relatively
positioned element is not rendered.

Example (full HTML in attachment):
--------------------
     .outer {  position: relative; }
     .inner {  position: absolute; top: 10px; left: 0px;  }
...
  BODY-TEXT
    <SPAN class="outer"> 
       BEGIN-OUTER
       <SPAN class="inner">
         INNER
       </SPAN>
       END-OUTER
    </SPAN>
  BODY-TEXT
--------------------

Above, "INNER" is rendered slightly below "BEGIN-OUTER", which is correct.
However, if you delete the text 'BEGIN-OUTER' and 'END-OUTER' then 'INNER' is
not rendered anywhere.

Tested in Mozilla 0.9.2.

This trick seems useful for adding annotation to text (without disturbing flow).
Is there a more elegant way of doing that?
(Reporter)

Comment 1

17 years ago
Created attachment 44245 [details]
testcase
Confirmed, 2001-08-01-03 on Windows 98 SE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Linux → All

Comment 3

17 years ago
Reassigning to attinasi.
Assignee: karnaze → attinasi

Updated

17 years ago
Target Milestone: --- → mozilla1.1
yet another block-in-inline problem.  Making the outer element a display:block
element makes things work...
Summary: [ABS POS] Absolute placement broken when container is empty → [ABS POS]{ib} Absolute placement broken when container is empty
Keywords: css2
.
Assignee: attinasi → block-and-inline
Component: Layout → Layout: Block & Inline
QA Contact: cpetersen0953 → ian
This was a dup of bug; it's fixed in current builds.

*** This bug has been marked as a duplicate of 79315 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.