crash in java.lang.ClassCastException: org.mozilla.gecko.home.TwoLinePageRow cannot be cast to org.mozilla.gecko.home.BookmarkFolderView at org.mozilla.gecko.home.BookmarksListAdapter.bindView(BookmarksListAdapter.java)

RESOLVED DUPLICATE of bug 929982

Status

()

Firefox for Android
Awesomescreen
--
critical
RESOLVED DUPLICATE of bug 929982
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

({crash, steps-wanted})

26 Branch
All
Android
crash, steps-wanted
Points:
---

Firefox Tracking Flags

(firefox26 affected, firefox27 affected)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-d5dd33a2-a394-4f9d-a502-191472131023.
=============================================================

java.lang.ClassCastException: org.mozilla.gecko.home.TwoLinePageRow cannot be cast to org.mozilla.gecko.home.BookmarkFolderView
	at org.mozilla.gecko.home.BookmarksListAdapter.bindView(BookmarksListAdapter.java:195)
	at org.mozilla.gecko.home.MultiTypeCursorAdapter.getView(MultiTypeCursorAdapter.java:62)
	at android.widget.HeaderViewListAdapter.getView(HeaderViewListAdapter.java:220)
	at android.widget.AbsListView.obtainView(AbsListView.java:1949)
(Reporter)

Updated

4 years ago
Blocks: 862793
status-firefox26: --- → affected
(Reporter)

Updated

4 years ago
status-firefox27: --- → affected
(Reporter)

Updated

4 years ago
Duplicate of this bug: 930740
Lucas said he was looking into this, thinking it's related to some other issues, so updating bug metadata.
Assignee: nobody → lucasr.at.mozilla
Status: NEW → ASSIGNED
(Reporter)

Comment 3

4 years ago
Looks like a growing crash on crash-stats. Status of the bug here?
tracking-firefox26: --- → ?
(Assignee)

Comment 4

4 years ago
I have potential fixes for this crash in bug 929982 (which is tracked for Fx26). Closing as dup.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929982
tracking-firefox26: ? → ---
You need to log in before you can comment on or make changes to this bug.