Closed Bug 930653 Opened 6 years ago Closed 6 years ago

TopSites grid displays as 4/2 columns/rows

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect)

x86
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

Attachments

(1 file)

On some tablets, the TopSites grid will layout at 4 columns and 2 rows, when there is clearly vertical space for the preferred 3x3 layout.
Looks like this was a regression introduced when we added the scale(0.9) transition to the richgrids. As the scaling affects the actual dimensions of the element, when arrangeItems was called, depending on the timing, it could determine that only 2 rows would fit. 

In the patch I've used translateY to nudge down 25px - it gives us the equivalent bounce or rise effect as 0.9 scale. On the slower/lower-power devices you don't get a lot of frames but a subtle effect is still visible on my Dell Latitude 10.
Assignee: nobody → sfoster
Attachment #822113 - Flags: review?(rsilveira)
Attachment #822113 - Flags: review?(rsilveira) → review+
https://hg.mozilla.org/mozilla-central/rev/aa6dec64e526
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.