cannot select contacts in export search mode

VERIFIED FIXED in Firefox OS v1.2

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

({regression})

unspecified
1.2 C4(Nov8)
x86_64
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

(Whiteboard: [c= p=1 s=2013.11.08 u=1.2])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
After landing bug 902873 its longer possible to select contacts in export search mode.

To reproduce:

  1) Launch contacts
  2) Go to settings->export->memory card
  3) Place cursor in search box to enter search mode
  4) Try tapping on a contact.  Nothing happens.

Its expected that the contact should be checked.

This occurs in latest v1.2 gaia.
(Assignee)

Comment 2

4 years ago
Comment on attachment 821903 [details] [review]
mozilla-b2g:master PR#13075

Francisco, it looks like we just lost the code to select the search node when we brought in the selection perf improvements.  I think this should fix the problem.  Sorry I didn't catch it during the review!
Attachment #821903 - Flags: review?(francisco.jordano)
(Assignee)

Comment 3

4 years ago
Since this reproduces on v1.2, block bug 916996.
Blocks: 916996
(Assignee)

Updated

4 years ago
Whiteboard: [c= p=1 s= u=]
Comment on attachment 821903 [details] [review]
mozilla-b2g:master PR#13075

Tried on the phone, working perfectly.

Thanks a lot Ben.
Attachment #821903 - Flags: review?(francisco.jordano) → review+

Updated

4 years ago
blocking-b2g: koi? → koi+
Keywords: regression, verifyme
(Assignee)

Comment 5

4 years ago
Thanks Francisco!  Landed on master:

  https://github.com/mozilla-b2g/gaia/commit/a47859f9c7f2a7ee18ab2fd660a17bdfd2d8a856

Based on koi+ I also uplifted to v1.2:

  https://github.com/mozilla-b2g/gaia/commit/fbab09a19bba73cc62e5975a14cdcd3898492aa1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.2: --- → fixed
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: [c= p=1 s= u=] → [c= p=1 s=2013.11.08 u=1.2]
Fix verified on Buri 1.2 commercial RIL.  Tapping a contact while on the contact search page now checks or unchecks the checkbox next to that contact.

Build ID: 20131107004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/26f1e160e696
Gaia: 590eb598aacf1e2136b2b6aca5c3124557a365ca
Platform Version: 26.0
RIL Version: 01.01.00.019.281
Status: RESOLVED → VERIFIED
status-b2g-v1.2: fixed → verified

Comment 7

4 years ago
Setting Target Milestone for this sprint's koi+ fixes.
Target Milestone: --- → 1.2 C4(Nov8)

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.