device can not reboot/poweroff successful

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: viralwang, Assigned: rexboy)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [FT:System-Platform])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
We met device can not reboot/poweroff successful in unagi and flatfish.

reboot/poweroff will be blocked since device enter suspend mode and freeze the userspace processes.
We need to wake up acpu again to resume device and complete reboot/poweroff.

reproduce steps:
1. use master gecko/gaia in unagi.
2. make sure no USB attached
3. long press power key and choose Restart

The reboot can not complete immediately, we can only found screen is off.
device will be reboot when acpu wake up (such as press power key and plug in USB)
(Reporter)

Comment 1

5 years ago
Hi Rex,

I'm guessing the code here is used to turn screen off.

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/sleep_menu.js#L305

however, it will make the device suspend and block all the userspace processes included poweroff and reboot.
Could you please help to take a look?
Thanks.
Blocks: 926836
Flags: needinfo?(rexboy)
Not sure if it's a regression.
We may not need to turn off screen when power-off as well, but I need some test to confirm it.
Assignee: nobody → rexboy
Flags: needinfo?(rexboy)
Created attachment 823868 [details]
patch

It's true that screenoff suspends all following actions. Let's try not to
screenoff before reboot/poweroff..
Tested OK for me both with/without custom boot animation.

Alive may you help review this simple patch?
Attachment #823868 - Flags: review?(alive)
Comment on attachment 823868 [details]
patch

r+ if UI looks O.K. after this change.
Attachment #823868 - Flags: review?(alive) → review+
Thank you Alive!

merged here:
https://github.com/mozilla-b2g/gaia/commit/1a5daa90ac49e1e83dc7902acc461acdb3606dde
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

5 years ago
Since it's a generic issue, shall we also apply it on 1.2?
blocking-b2g: --- → koi?

Updated

5 years ago
Whiteboard: [FT:System-Platform]
triage: this is a regression caused by power off animation implementation. koi+
blocking-b2g: koi? → koi+
Keywords: regression
Uplifted 1a5daa90ac49e1e83dc7902acc461acdb3606dde to:
v1.2: eb707a60302e86add4ec1beba3519ab957cdf3a8
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.