Closed Bug 931371 Opened 8 years ago Closed 6 years ago

Debug build (TB - trunk) fails with: fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO

Categories

(Firefox Build System :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: infofrommozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131009120945

Steps to reproduce:

I did a debug build from tb trunk.

ac_add_options --disable-optimize
ac_add_options --enable-debug
ac_add_options --enable-debug-symbols
ac_add_options --disable-tests
ac_add_options --enable-logging
ac_add_options --disable-safe-browsing
ac_add_options --disable-update-packaging
ac_add_options --disable-crashreporter



Actual results:

Build log:
[...]
   Creating library xul.lib and object xul.exp

LINK : warning LNK4098: defaultlib 'LIBCMTD' conflicts with use of other libs; use /NODEFAULTLIB:library

MediaPipeline.obj : warning LNK4049: locally defined symbol _NS_DebugBreak imported
[... a lot more warnings sniped]
LINK : fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO
[...]
My build environment is:
o VS2010 Express
o MS Windows SDK 7.0
o Direct X SDK June 2010

on Windows XP 32bit
From other reports (from the #developers IRC channel) it looks like this might be a Windows 32-bit only issue (32bit Windows has a different memory limit compared to 64bit, see http://connect.microsoft.com/VisualStudio/feedback/details/283665/increase-linker-memory-to-avoid-linker-error-lnk1210-exceeded-internal-ilk-size-limit). Bug should still get fixed, but maybe this slows down a possible fix. For a workaround you could try to apply the patch from Bug 653662 to your local build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Debug buld (TB - trunk) fails with: fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO → Debug build (TB - trunk) fails with: fatal error LNK1210: exceeded internal ILK size limit; link with /INCREMENTAL:NO
(In reply to Frank Wein [:mcsmurf] from comment #2)
> might be a Windows 32-bit only issue (32bit Windows has a different memory
> limit compared to 64bit, see

The linker has a file size limitation of the ILK files.

[your link]
| In VS 2008, we did increase the ILK size limit for /3GB from 256MB to 384MB,
| and when running under WoW64 on a 64-bit machine from 384MB to 768MB.

> limit). Bug should still get fixed, but maybe this slows down a possible
> fix.

As a workaround I have set the /3GB flag.
That helped. I was able to successfully create a debug build.

While building the xul.ilk was 256MB in size. And at the end the file had a size of 210MB.
Ok, since this is now outdated, I close the bug as 'WORKSFORME'.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.