"nsICacheEntryOpenCallback is not defined" in pageInfo.js, test_clearHistory_shutdown.js

RESOLVED FIXED in Firefox 27

Status

()

Firefox
Page Info Window
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: mayhemer)

Tracking

({regression})

Trunk
Firefox 28
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
JavaScript error: chrome://browser/content/pageinfo/pageInfo.js, line 474: nsICacheEntryOpenCallback is not defined

I don't have a reliable way to reproduce, but looking at the JS, I don't see where that identifier is ever declared.
(Reporter)

Comment 1

4 years ago
Two files have this line:

browser/base/content/pageinfo/pageInfo.js
browser/components/places/tests/unit/test_clearHistory_shutdown.js
(Assignee)

Comment 2

4 years ago
Definitely just needs _Ci._nsICacheEntryOpenCallback;  Easy to fix.  The onCacheEntryCheck is called when the entry to examine is in the cache.  If not, that callback is not invoked.
(Assignee)

Comment 3

4 years ago
Created attachment 825462 [details] [diff] [review]
v1
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Attachment #825462 - Flags: review?(jruderman)
Comment on attachment 825462 [details] [diff] [review]
v1

browser/components/places/tests/unit/test_clearHistory_shutdown.js has the same bug.
Attachment #825462 - Flags: review?(jruderman) → review-

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86_64 → All
Comment on attachment 825462 [details] [diff] [review]
v1

test_clearHistory_shutdown.js is "fixed" in this patch... But nsICacheEntryOpenCallback.ENTRY_VALID doesn't seem to exist?
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #5)
> Comment on attachment 825462 [details] [diff] [review]
> v1
> 
> test_clearHistory_shutdown.js is "fixed" in this patch...

Oops, yes, I only saw the first chunk and assumed there was nothing else, according to the bug summary.

> But nsICacheEntryOpenCallback.ENTRY_VALID doesn't seem to exist?

True.
Summary: "nsICacheEntryOpenCallback is not defined" in pageInfo.js → "nsICacheEntryOpenCallback is not defined" in pageInfo.js, test_clearHistory_shutdown.js
(Assignee)

Comment 7

4 years ago
Created attachment 826713 [details] [diff] [review]
v2

- added missing Components.interfaces
- s/ENTRY_VALID/ENTRY_WANTED/

Thanks for catching all the mistakes.
Attachment #825462 - Attachment is obsolete: true
Attachment #826713 - Flags: review?(dao)
Comment on attachment 826713 [details] [diff] [review]
v2

Thanks!
Attachment #826713 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/b1ce58dc63d0
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
(Assignee)

Comment 11

4 years ago
Comment on attachment 826713 [details] [diff] [review]
v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 913807
User impact if declined: none, since the code behaves the same, just prints false warning in debug builds
Testing completed (on m-c, etc.): just landed on m-c
Risk to taking this patch (and alternatives if risky): zero
String or IDL/UUID changes made by this patch: none

It's no problem NOT TO take this patch on m-a.
Attachment #826713 - Flags: approval-mozilla-aurora?
Comment on attachment 826713 [details] [diff] [review]
v2

Approving to avoid the regression, given how trivial the change is and since its super low risk.
Attachment #826713 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/11b4854b7cdf
status-firefox27: --- → fixed
status-firefox28: --- → fixed

Updated

4 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.