Deprecate and remove CanvasRenderingContext2D.mozDash/mozDashOffset

RESOLVED FIXED in Firefox 52

Status

()

Core
Canvas: 2D
RESOLVED FIXED
4 years ago
7 months ago

People

(Reporter: Ms2ger, Assigned: Thomas Wisniewski)

Tracking

(Blocks: 1 bug, {addon-compat, dev-doc-complete, site-compat})

unspecified
mozilla52
addon-compat, dev-doc-complete, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Originally part of bug 768067, but didn't happen there.
(Reporter)

Updated

a year ago
Duplicate of this bug: 931643
(Reporter)

Updated

a year ago
Blocks: 768067
Summary: Deprecate and remove CanvasRenderingContext2D.mozDash → Deprecate and remove CanvasRenderingContext2D.mozDash/mozDashOffset
(Assignee)

Comment 2

11 months ago
Created attachment 8791582 [details] [diff] [review]
931389-remove-mozDash-and-mozDashOffset.diff

Since the unprefixed versions of these features have been in Firefox since version 27, the MDN page for the standard version has noted that they're deprecated since at least July of last year, and no addons on DXR are only using the prefixed versions, I think it's probably safe to go ahead and remove them now. Here's a patch which does so. Try seems fine: https://treeherder.mozilla.org/#/jobs?repo=try&revision=035996f88667

Intent to unship: https://groups.google.com/forum/#!topic/mozilla.dev.platform/UIudMABegcY
Assignee: nobody → wisniewskit
Status: NEW → ASSIGNED
Attachment #8791582 - Flags: review?(gwright)
Comment on attachment 8791582 [details] [diff] [review]
931389-remove-mozDash-and-mozDashOffset.diff

Review of attachment 8791582 [details] [diff] [review]:
-----------------------------------------------------------------

I'm ok with this, but let's give dev-platform a little more time to raise any possible objections.
Attachment #8791582 - Flags: review?(gwright) → review+
(Assignee)

Comment 4

11 months ago
I still haven't received any feedback on the dev-platform thread, George. Would you still like to wait a while longer?
Flags: needinfo?(gwright)
Nope, let's go ahead with this.
Flags: needinfo?(gwright)
(Assignee)

Comment 6

11 months ago
Created attachment 8797719 [details] [diff] [review]
931389-remove-mozDash-and-mozDashOffset.diff

Alright then. Here's a rebased version of the patch. A fresh try run* seems fine, so I'm carrying over r+ and requesting check-in.

* https://treeherder.mozilla.org/#/jobs?repo=try&revision=dbc5436cc4cb2f370c38806703dda9126f64f00d
Attachment #8791582 - Attachment is obsolete: true
(Assignee)

Updated

11 months ago
Keywords: checkin-needed

Comment 7

11 months ago
Posted the site compatibility doc: https://www.fxsitecompat.com/en-CA/docs/2016/canvas-2d-mozdash-and-mozdashoffset-have-been-removed/
The webidl changes need DOM peer review.
Keywords: checkin-needed
Attachment #8797719 - Flags: review+
Keywords: checkin-needed

Comment 9

11 months ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/68ec683e9a5c
remove CanvasRenderingContext2D.mozDash/mozDashOffset. r=gw280, r=baku
Keywords: checkin-needed

Comment 10

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/68ec683e9a5c
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
I think that since these have been marked for obsolescence for so long, have been removed completely, and were Gecko-only anyway, they can be removed from the docs. I've removed the mentions from
https://developer.mozilla.org/en-US/docs/Web/API/CanvasRenderingContext2D#Non-standard_APIs

I've also added a note to the Fx52 release notes:
https://developer.mozilla.org/en-US/Firefox/Releases/52#Others
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.