Closed Bug 931420 Opened 8 years ago Closed 8 years ago

Lightning 2.6.1 install.rdf should have Thunderbird minVersion of 24.0.1

Categories

(Calendar :: General, defect)

Lightning 2.6.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: heinz.repp, Assigned: Fallen)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911160237



Actual results:

When Lightning auto-updates on any Ubuntu (who have only Thunderbird 24.0 in their repositories and did not update to 24.0.1 until now) Lightning does not work any more, shows a completely empty grid with distorted chrome. You know perfectly that Lightning 2.6.1 does not work on Thunderbird 24.0, so why is install.rdf listing a minVersion 24.0 for Thunderbird and not 24.0.1 as it should read?
Summary: Lightning 2.6.1 install.rdf should have Thnunderbird minVersion of 24.0.1 → Lightning 2.6.1 install.rdf should have Thunderbird minVersion of 24.0.1
Philipp, could you please correct min and max version on addons.mozilla.org to ensure we don't automatically update Linux users to a version that is known to not work together?
Status: UNCONFIRMED → NEW
Ever confirmed: true
AMO doesn't have those versions available as accepted appversions yet. I had written the admins an email and jorgev will take care of that later today. Afterwards, I can set up the min/maxversions correctly.
I've fixed this by changing the versions via the UI on AMO. I hope this actually works. I've tested on mac and got the right updates, but I've read a comment that it doesn't work too.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.6.1
Assignee: nobody → philipp
I can confirm that it works now for Thunderbird 24.0 on Ubuntu (they still did not react to the launchpad bug 1244619) - asking Lightning 2.6 for updates returns nothing as it should be. Btw, did you fix 2.6's maxVersion also (it should read 24.0)?
What about the files in https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/releases/2.6? Will it be fixed in the xpi / source package for e.g. 2.6.1 before uploading?
No, I didn't change anything in the releases dir, nor did I retag the builds. I guess we can do that in this bug. I cannot change the xpi on AMO itself, the min/maxversion is just a UI / updates change.

I've changed min and maxversion to the same respective value for 2.6 - 2.6.2.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
What is the status here? Is the minVersion/maxVersion issue relsolved for 2.6.4 on AMO and Source?
Philipp, any update here?
Attached file Outgoing on comm-esr24
Ok, this was far more annoying than I thought. I spent way too much time writing a script to do the maxversion changes in batch and the manual steps also took ages.

* I've fixed 2.6 - 2.6.3 on ftp.mozilla.org
  - Changed the min/maxversion to match what is on Calendar_Versions on mdn
  - Updated the source to use @THUNDERBIRD_VERSION@ as the maxversion

* I have attached my outgoing changesets which I want to push to comm-esr24
  - Changes maxversion to @THUNDERBIRD_VERSION@ as above
  - Can't do this for 24.1.0 since it uses the same relbranch as 24.1.1

Mark, can you take a look at this to make sure its sane?
Attachment #8384168 - Flags: review?(standard8)
Comment on attachment 8384168 [details]
Outgoing on comm-esr24

I don't understand why you want to do this. This would mean that you have to download a new version of lightning each time, whereas the advantage with being on the 24.x tree is that you don't.
Attachment #8384168 - Flags: review?(standard8)
Mark, these commits are (unless I did something wrong), just to fix the problem for the 2.6, 2.6.1, 2.6.2, 2.6.3 releases, which were affected by bug 927073. 

I don't really think anyone is going to build these versions, but if they do pull from hg using a tag from one of the affected builds, i.e. THUNDERBIRD_24_0_1_RELEASE, they should get a Lightning that is only compatible to this release.

2.6.4 and on should continue to use @THUNDERBIRD_MAXVERSION@. Makes sense?
Flags: needinfo?(standard8)
Comment on attachment 8384168 [details]
Outgoing on comm-esr24

Ah ok, r+a=Standard8.
Attachment #8384168 - Flags: review+
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.