GStreamerLoader.cpp:47:24: error: ‘nullptr’ was not declared in this scope

RESOLVED FIXED in Firefox 27

Status

()

Core
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: WG9s, Assigned: WG9s)

Tracking

({regression})

Trunk
mozilla28
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Another nullptr issue.
(Assignee)

Comment 1

4 years ago
Created attachment 822848 [details] [diff] [review]
Patch
Attachment #822848 - Flags: review?
(Assignee)

Updated

4 years ago
Attachment #822848 - Flags: review? → review?(ehsan)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED

Updated

4 years ago
Attachment #822848 - Flags: review?(ehsan) → review+

Comment 2

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/19e0d06f37e8
https://hg.mozilla.org/mozilla-central/rev/19e0d06f37e8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
(Assignee)

Comment 4

4 years ago
Comment on attachment 822848 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 784739
User impact if declined: released source will not compile with GCC 4.5
Testing completed (on m-c, etc.): Patch has been on mozilla-central since 10/28/2013
Risk to taking this patch (and alternatives if risky): very little risk trivial fix
String or IDL/UUID changes made by this patch: none
Attachment #822848 - Flags: approval-mozilla-beta?
(Assignee)

Comment 5

4 years ago
I nominated this because it seems from comments in bug 931427 that there is an intention to have the beta and released source compile under GCC 4.5.

Updated

4 years ago
Attachment #822848 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/d81ce166fe8e
status-firefox27: --- → fixed
status-firefox28: --- → fixed
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.