Mac: Full-page plugins don't get adjustCursorEvent events

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: lmcquarr, Assigned: Peter Lubczynski)

Tracking

(Depends on: 1 bug)

Trunk
Future
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [acrobat][PL2:NA], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)
BuildID:    2001080108

Mac only problem -- multiple OS versions.

On the Mac in Netscape 6.1/Mozilla, when the PDF file has a form field on it,
the cursor is always an arrow.  It never becomes a hand cursor.    If the file
does not have a form field, the hand cursor appears.

Note however that the hand cursor functionality still works -- you can drag the 
page
with the cursor and scroll through the file.  It is, thererfore, just a cosmetic 
thing.

Why this is happening only in Netscape 6.1/mozilla, and not in Mac IE 5 or
Netscape 4.X, is yet to be determined.


Reproducible: Always
Steps to Reproduce:
1 - Acrobat 5.0
2 - Browse to http://access.adobe.com/browser/cookbook.pdf (or any PDF file)- 
notice that the cursor is a hand cursor.
3 - Browse to any PDF file with a form field, e.g. 
http://access.adobe.com/browser/pingform.pdf   Notice that
the cursor is always an arrow. 



Actual Results:  When PDF file has a form field, cursor is always an arrow. 
Note, however, that the hand tool functionality still works --
you can grab the page and move it. 

Expected Results:  Cursor is a hand when not over form field. 

I do not yet know why this is happening (what problem in the
implementation of the NS API that is causing mozilla/Netscape 6.1
to have this problem and not Netscape 4.X or Mac IE 5.X).

Comment 1

17 years ago
hm..i cannot seem to be able to connect to access.adobe.com. anyone else seeing 
this? :(

Comment 2

17 years ago
dah..took 5 mins..but i can finally see it.
(Reporter)

Comment 3

17 years ago
Hi folks:

It turns out that we are getting NO cursor events on the mac. 
This means that we NEVER change the cursor, no matter what
tool is selected.

For example, the default tool is the "hand tool" (a little hand),
that allows you to scroll the page by moving it with the hand.

If you choose the zoom tool, the cursor should change to a "+".
It does not change, but the functionality still works.

I gave you folks a copy of Acrobat plug=in to Netscape (did I give
you the mac version as well?  If not, and you want it, let
me know).

In that code (NS_pdfx.cpp), there is a NPP_HandleEvent function
for the mac.  In that function, there is this code for an
adjustCursor event:

	case adjustCursorEvent:
			static Point lastADJ = {0,0};
			if ( EqualPt(evt->where, lastADJ) )
				break;	/* skip it */
			else
				lastADJ = evt->where;


With Netscape 6.1, that code is never being called.  We 
are not, therefore, getting any adjustCursorEvents. 

(You can compare this to NS 4.X or IE 5.X ...)

Let me know if you need the mac project files for the
Acrobat plug-in.
Summary: PDF File With Form Field Always Displays Arrow Cursor → Cursor Events Not Coming on The Mac
(Assignee)

Comment 4

17 years ago
Mac plugin bug---->peterl
Assignee: av → peterlubczynski
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
OS: Windows NT → All
Priority: -- → P3
Summary: Cursor Events Not Coming on The Mac → Full-page plugins need MouseMotionListener for plugin cursor events
Target Milestone: --- → mozilla0.9.5
(Assignee)

Updated

17 years ago
Depends on: 90256
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.9
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1
(Reporter)

Comment 5

16 years ago
Now that we are past most of the crashers and Acrobat forms-related bugs,
I would like to nominate this bug for consideration.  Unfortunately, it is
still an issue. 

This is more than cosmetic:  it is a useability issue.  The different
cursors in Acrobat indicate what tool/mode is enabled.  Some examples:

+ If the user sees the hand tool, that means he/she can use the cursor to scroll 
the page.
+ The cursor changes over a link to let a user know that that page there
is "hot".   
+ The cursor changes over a form field to let the user know
that they can type.  
ETC.

It is not, however, a crasher or does not block functionality.  The priority,
therefore, is not "critical". 

(Assignee)

Comment 6

16 years ago
Yeah, the code around there looks scarry and needs to be cleaned up. See bug 144876.
No longer depends on: 90256
Keywords: 4xp
Summary: Full-page plugins need MouseMotionListener for plugin cursor events → Mac: Full-page plugins don't get adjustCursorEvent events
Whiteboard: [acrobat]
(Reporter)

Updated

16 years ago
Depends on: 144876

Comment 7

16 years ago
moving to 1.1
Target Milestone: mozilla1.0.1 → mozilla1.1alpha
(Assignee)

Updated

16 years ago
Whiteboard: [acrobat] → [acrobat][PL2:NA]
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.1alpha → Future
QA Contact: shrir → plugins

Comment 8

7 years ago
If this is still a problem (I doubt it), we're not going to fix it because we're not going to mess with Carbon plugin support any more. It will be removed soon.

Marking WFM since I haven't heard any reports of problems with this in a while. I remember fixing some related bugs years ago.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.