Tapping an .apk file download link results in 2 downloads starting, one of which never completes

VERIFIED FIXED in Firefox 27

Status

()

defect
--
major
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: wgianopoulos, Assigned: wgianopoulos)

Tracking

({regression, reproducible})

27 Branch
Firefox 28
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28 verified, fennec27+)

Details

Attachments

(1 attachment)

Clicking on a download link such as http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/fennec-27.0a1.multi.android-arm.apk results in 2 downloads starting instead of 1.  One of the 2 downloads never completes.

Regression window http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=23c23b472a4f&tochange=177bf37a49f5
Looks like perhaps bug 780379.  I will try backing it out and report back.
I have verified via backout, that the following check-in for bug 780379 is the regressor here:

http://hg.mozilla.org/mozilla-central/rev/04f77c1e3337
Blocks: 780379
Summary: Clicking on a download link results in 2 downloads starting, one of which never completes → Tapping a .apk file download link results in 2 downloads starting, one of which never completes
tracking-fennec: --- → ?
Version: Trunk → Firefox 27
Possibly also related to the occasional "Unfortunately, Fennec has stopped" notification I get when triggering a download?
Wes, see Bug 780379 Comment 55.
Flags: needinfo?(wjohnston)
Hardware: ARM → All
Summary: Tapping a .apk file download link results in 2 downloads starting, one of which never completes → Tapping an .apk file download link results in 2 downloads starting, one of which never completes
Assignee: nobody → wgianopoulos
Attachment #822994 - Flags: review? → review?(wjohnston)
I should give credit here to :rnewman.  It was his comment above that led to this fix.
Flagging for tracking in case this misses the merge.
Status: NEW → ASSIGNED
Keywords: reproducible
Duplicate of this bug: 931698
Attachment #822994 - Flags: review?(wjohnston) → review+
Flags: needinfo?(wjohnston)
Whiteboard: check-in needed
It is hard to get testing on this since the tree is closed so it can't land, but I am including this in my own daily builds available at my own website http://www.wg9s.com/mozilla/firefox/
Keywords: checkin-needed
Whiteboard: check-in needed
tracking-fennec: ? → 27+
https://hg.mozilla.org/mozilla-central/rev/858d68a25e5d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Looks good on trunk, please nominate for Aurora.
Status: RESOLVED → VERIFIED
I was planning on letting it bake for a week, unless you think I should just do it sooner.
(In reply to Bill Gianopoulos [:WG9s] from comment #13)
> I was planning on letting it bake for a week, unless you think I should just
> do it sooner.

Only if the patch was more complicated. This looks like a simple typo-fix. Sooner is better.
Comment on attachment 822994 [details] [diff] [review]
Remove redundant app.launch(aLauncher.source)

[Approval Request Comment]
Bug caused by (feature/regressing bug #):  780379
User impact if declined: Results in a nasty regression when using the browser to download files.
Testing completed (on m-c, etc.): Is on m-c.
Risk to taking this patch (and alternatives if risky): Not risky, essentially a typo-fix.
String or IDL/UUID changes made by this patch: none
Attachment #822994 - Flags: approval-mozilla-aurora?
Attachment #822994 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on build: aurora 27.0a2 (11.13.2013).
Device: Asus Transformer Tab (Android 4.0.3)
Blocks: 942356
No longer blocks: 942356
You need to log in before you can comment on or make changes to this bug.