Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Implement 'opacity' according to the spec (transparency)

VERIFIED FIXED in mozilla1.7beta

Status

()

Core
CSS Parsing and Computation
P2
enhancement
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Pierre Saslawsky, Assigned: dbaron)

Tracking

({css3})

Trunk
mozilla1.7beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This bug is extracted from bug 58517.  Dbaron wrote:

The '-moz-opacity' property doesn't match the recommendation for 'opacity':

'-moz-opacity' is inherited and applies only to any painting done for the element 
(at least it did the last time I checked)

'opacity' is not inherited and should apply to the entire subtree drawn by the
element

The former is totally wrong and only works reasonably in certain simple cases.

--------------

I looked into the way we use '-moz-opacity' and it doesn't seem that we are 
already taking advantage of the difference between the two definitions. So, 
unlike what I wrote in bug 58517 [2001-07-17 16:31], the way to go would be to 
fix '-moz-opacity' when we can, and rename it to 'opacity' as soon as the spec 
becomes a recommendation.
(Reporter)

Comment 1

16 years ago
*** Bug 58517 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

16 years ago
Severity: normal → enhancement

Updated

15 years ago
Summary: [rfe] Implement 'opacity' according to the spec → Implement 'opacity' according to the spec

Comment 2

15 years ago
What are the current plans - intending to further develop -moz-opacity or 
focus on being according to the spec?

Comment 3

14 years ago
URL of [now published] spec should be: http://www.w3.org/TR/css3-color/#transparency

(sorry, i don't have the privs to add it myself.)

Updated

14 years ago

Comment 4

14 years ago
The CSS3 Color module has now moved to Candidate Recommendation. Can we proceed 
to fix this bug now?
(Assignee)

Comment 5

14 years ago
This is basically a duplicate of bug 212366, but this can cover renaming
'-moz-opacity' to 'opacity' while still supporting '-moz-opacity' (at least for
a while).
Depends on: 212366
(Assignee)

Comment 6

14 years ago
Taking to cover the renaming, which should wait until it works on Mac.
Assignee: kmcclusk → dbaron
Status: ASSIGNED → NEW
Component: GFX → Style System (CSS)
QA Contact: chrispetersen → ian

Comment 7

14 years ago
adding transparency synonym
Summary: Implement 'opacity' according to the spec → Implement 'opacity' according to the spec (transparency)
(Assignee)

Updated

14 years ago
Depends on: 228441

Updated

14 years ago
Keywords: css3
(Assignee)

Comment 8

14 years ago
Created attachment 142085 [details] [diff] [review]
patch

I've tested that each of the following:

javascript:void(alert(document.body.style.Opacity));
javascript:void(alert(document.body.style.MozOpacity));

work both without any of the following and after each of them:

javascript:void(document.body.setAttribute("style", "opacity: 0.8"));
javascript:void(document.body.setAttribute("style", "-moz-opacity: 0.6"));
javascript:void(document.body.style.Opacity = "0.2");
javascript:void(document.body.style.MozOpacity = "0.4");
(Assignee)

Updated

14 years ago
Attachment #142085 - Flags: superreview?(roc)
Attachment #142085 - Flags: review?(bzbarsky)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [patch]
Target Milestone: Future → mozilla1.7beta
Comment on attachment 142085 [details] [diff] [review]
patch

It doesn't quite work according to spec yet (e.g., multiple boxes for the same
element aren't collapsed into the same opacity group) but I agree it's good
enough.
Attachment #142085 - Flags: superreview?(roc) → superreview+

Comment 10

14 years ago
Comment on attachment 142085 [details] [diff] [review]
patch

r=bzbarsky.
Attachment #142085 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 11

14 years ago
Fix checked in to trunk, 2004-02-23 22:48 / 23:37 -0800.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Robert, is there any bug related to that problem?
+           attribute DOMString        Opacity;

Shouldn't that be 'opacity'? (lowercase)

Comment 14

14 years ago
Folks, I believe it should be "opacity" and not "Opacity", like this:

ElemRef.style.opacity = strValue;

My 2 cents
oops yeah, missed that. It should be lowercase.

Zbigniew, I don't think there's a bug on that. I'm planning to fix it as part of
some significant painting changes that I'm working on.
(Assignee)

Comment 16

14 years ago
Case corrected.

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.