Closed Bug 93167 Opened 22 years ago Closed 21 years ago

&GroupExists and &GroupIsActive should push and pop sql state

Categories

(Bugzilla :: Bugzilla-General, defect, P2)

2.13
x86
Linux
defect

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: myk, Assigned: bbaetz)

References

Details

(Whiteboard: applied to 2.14.2)

Attachments

(2 files)

Those three functions do not call &PushGlobalSQLState or &PopGlobalSQLState, but
they should in order "to avoid sometimes mysterious dataloss type bugs"
according to a comment by Jake in bug 39816.
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
I fixed UserInGroup because I need that to work for another bug. Updating summary.
Summary: &UserInGroup, &GroupExists, and &GroupIsActive should push and pop sql state → &GroupExists and &GroupIsActive should push and pop sql state
Trivial patch, which will fix a 2.16 regression. This is also needed for 2.14.2;
2.14.2 needs UserInGroup fixed, too.
Assignee: justdave → bbaetz
Blocks: 148687
Keywords: patch, review
Whiteboard: wanted for 2.14.2
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16
Attached patch v1Splinter Review
Comment on attachment 86002 [details] [diff] [review]
v1

r= justdave
Attachment #86002 - Flags: review+
Attached patch v1, 2.14 versionSplinter Review
Comment on attachment 86003 [details] [diff] [review]
v1, 2.14 version

r= justdave
Attachment #86003 - Flags: review+
Comment on attachment 86002 [details] [diff] [review]
v1

r=jouni
Attachment #86002 - Flags: review+
Comment on attachment 86003 [details] [diff] [review]
v1, 2.14 version

r=jouni
Attachment #86003 - Flags: review+
Checked into 2.14, 2.16, and HEAD

Checking in globals.pl;
/cvsroot/mozilla/webtools/bugzilla/globals.pl,v  <--  globals.pl
new revision: 1.110.2.7; previous revision: 1.110.2.6
done

Checking in globals.pl;
/cvsroot/mozilla/webtools/bugzilla/globals.pl,v  <--  globals.pl
new revision: 1.169.2.2; previous revision: 1.169.2.1
done

Checking in globals.pl;
/cvsroot/mozilla/webtools/bugzilla/globals.pl,v  <--  globals.pl
new revision: 1.172; previous revision: 1.171
done
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Whiteboard: wanted for 2.14.2 → applied to 2.14.2
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.