When you enter your login or password wrong, the error message shown "The username or password you entered is not valid" should be edited to "The login or password you entered is not valid"

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: tinajohnson.1234, Assigned: tinajohnson.1234)

Tracking

4.5.1
Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Created attachment 823306 [details]
Wrong error message. It should display, "The email-id or password you entered is not valid.  "

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1 (Beta/Release)
Build ID: 20120907231657

Steps to reproduce:

When I entered my email-id wrong, I encountered the wrong message.


Actual results:

Error message:"The username or password you entered is not valid. "


Expected results:

"The email-id or password you entered is not valid. "

Comment 1

4 years ago
(In reply to tinajohnson.1234 from comment #0)
> Expected results:
> 
> "The email-id or password you entered is not valid. "

It should say "login", not "email-id".
Assignee: general → ui
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Component: Bugzilla-General → User Interface
Ever confirmed: true
Summary: When you enter your email-id or password wrong, the error message shown "The username or password you entered is not valid. " should be edited to "The email-id or password you entered is not valid. " → When you enter your login or password wrong, the error message shown "The username or password you entered is not valid" should be edited to "The login or password you entered is not valid"
(Assignee)

Comment 2

4 years ago
(In reply to Frédéric Buclin from comment #1)
> (In reply to tinajohnson.1234 from comment #0)
> > Expected results:
> > 
> > "The email-id or password you entered is not valid. "
> 
> It should say "login", not "email-id".
When I checked the bugzilla's of Mozilla, KDE, MediaWiki the placeholders of the login input field was email-id. But "login" works too.

Comment 3

4 years ago
(In reply to tinajohnson.1234 from comment #2)
> (In reply to Frédéric Buclin from comment #1)
> > It should say "login", not "email-id".
> When I checked the bugzilla's of Mozilla, KDE, MediaWiki the placeholders of
> the login input field was email-id. But "login" works too.

That's because those three Bugzillas only allow email addresses as logins.
However Bugzilla's configuration also allows LDAP usernames for example, so "email-id" would be wrong.

Updated

4 years ago
Assignee: ui → tinajohnson.1234
(Assignee)

Comment 4

4 years ago
Created attachment 825936 [details] [diff] [review]
Error message and header title for invalid login changed.

Error message for invalid login changed from "The username or password you entered is not valid." to "The login or password you entered is not valid.". Also changed the header title from 'Bugzilla – Invalid Username Or Password' to 'Bugzilla – Invalid Login Or Password'
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED

Comment 5

4 years ago
Comment on attachment 825936 [details] [diff] [review]
Error message and header title for invalid login changed.

Review of attachment 825936 [details] [diff] [review]:
-----------------------------------------------------------------

+1 Essential as the error message is misleading in the bugzilla login.
Comment on attachment 825936 [details] [diff] [review]
Error message and header title for invalid login changed.

Change looks fine although I had to do patch -p1 to get it to apply. Please created your future diffs from within the root bugzilla directory. r=dkl

Thanks
dkl
Attachment #825936 - Flags: review+

Updated

4 years ago
Flags: approval?

Comment 7

4 years ago
Comment on attachment 825936 [details] [diff] [review]
Error message and header title for invalid login changed.

>   [% ELSIF error == "invalid_username_or_password" %]

I think the error tag should also be reworded to invalid_login_or_password.
(In reply to Frédéric Buclin from comment #7)
> Comment on attachment 825936 [details] [diff] [review]
> Error message and header title for invalid login changed.
> 
> >   [% ELSIF error == "invalid_username_or_password" %]
> 
> I think the error tag should also be reworded to invalid_login_or_password.

Ah good point and sorry missed that. Can fix on check in unless you think a new patch is in order.

dkl
(Assignee)

Comment 9

4 years ago
(In reply to David Lawrence [:dkl] from comment #8)
> (In reply to Frédéric Buclin from comment #7)
> > Comment on attachment 825936 [details] [diff] [review]
> > Error message and header title for invalid login changed.
> > 
> > >   [% ELSIF error == "invalid_username_or_password" %]
> > 
> > I think the error tag should also be reworded to invalid_login_or_password.
> 
> Ah good point and sorry missed that. Can fix on check in unless you think a
> new patch is in order.
I'll upload the patch soon.
> 
> dkl
(Assignee)

Comment 10

4 years ago
Created attachment 826285 [details] [diff] [review]
Error message and header title and error tag of invalid login changed in user-error.html.tmpl, Auth.pm, Constants.pm

Comment 11

4 years ago
Comment on attachment 826285 [details] [diff] [review]
Error message and header title and error tag of invalid login changed in user-error.html.tmpl, Auth.pm, Constants.pm

Review of attachment 826285 [details] [diff] [review]:
-----------------------------------------------------------------

looks done, this time.
Comment on attachment 826285 [details] [diff] [review]
Error message and header title and error tag of invalid login changed in user-error.html.tmpl, Auth.pm, Constants.pm

Not sure if a new patch was needed but since it's here, it needs a new review.
Attachment #826285 - Flags: review?(dkl)

Updated

4 years ago
Flags: approval? → approval+

Comment 13

4 years ago
The patch should be reviewed *before* being approved....
Comment on attachment 826285 [details] [diff] [review]
Error message and header title and error tag of invalid login changed in user-error.html.tmpl, Auth.pm, Constants.pm

r=dkl
Attachment #826285 - Flags: review?(dkl) → review+

Updated

4 years ago
Flags: approval+ → approval?

Updated

4 years ago
Target Milestone: --- → Bugzilla 5.0

Updated

4 years ago
Flags: approval? → approval+
Thanks for the patch!

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified Bugzilla/Auth.pm
modified Bugzilla/WebService/Constants.pm
modified template/en/default/global/user-error.html.tmpl
Committed revision 8805.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Attachment #825936 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.