Closed Bug 931839 Opened 8 years ago Closed 8 years ago

vrisko.gr mobile site redirect is broken on Firefox for Android

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alefteris, Unassigned)

References

()

Details

(Whiteboard: [country-gr][clientsniff])

Site: http://www.vrisko.gr
vrisko.gr mobile site redirect is broken on Firefox for Android

:: Steps To Reproduce

1. Open Firefox for Android app
2. Type vrisko.gr in Firefox for Android address bar

:: Expected Result

Get redirected to http://m.vrisko.gr. When typing the web site address on iOS Safari or Firefox OS we get redirected to the mobile site.

:: Actual Result

For an instant we are redirected to the mobile site and then back to the desktop version with the url http://www.vrisko.gr/?nomobile=true

:: Additional Information

Firefox for Android Beta
Software Version: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0
Device Information: ZTE Blade
This one is interesting. If you load m.vrisko.gr in Firefox for Android, you'll notice it loads then quickly jumps over to the desktop site.

For whatever reason, if you're an Android or iOS device and haven't already been redirected to the desktop site (in the same session), you get sent to http://www.vrisko.gr/?nomobile=true. Once you've been there and re-visit m.vrisko.gr, you get the mobile site (because you've now got a "informed" key in sessionStorage).

function hasVisited() {
        if (typeof (sessionStorage) != 'undefined') {
            try {
                // an to exei episkeftei toulaxiston mish wra prin...
                var now = new Date();
                if (sessionStorage.getItem("informed") != null) {
                    if ((now.getTime() - Date.parse(sessionStorage.getItem("informed"))) > (1 * 60 * Math.pow(10, 3))) {
                        return false;
                    }
                }
                else
                    return false;
                    
                return true;

            } catch (e) { /* katapiola */ }
        }
    }
    
    // inform iPhone/iPod/iPad visitors for our apple application
    function informVisitors() {
        if (!hasVisited()) {
            if (window.location.href.indexOf('informed') == -1) {
                if (isiPhone() || isAndroid()) {
                    storeVisit();
                    window.location.href = "http://www.vrisko.gr/?nomobile=true";
                }
            }
        }
    }

I assume this is part of their strategy to "encourage" people to use their native apps? This appears to be by design, so apart from asking them to be nicer to their users, there doesn't appear to be any bugs here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr][clientsniff][contactready]
Whiteboard: [country-gr][clientsniff][contactready] → [country-gr][clientsniff][sitewait]
I send an email at the address found at http://www.vrisko.gr/Contact.aspx
I got a reply from them. They have fixed the issue where if you went directly to m.vrisko.gr, they would redirect you to the desktop site. They also mentioned that they serve the desktop version for all Android and iOS browsers and they don't redirect to the mobile site. Firefox OS still gets redirected to the mobile site. So I think we can mark this as resolved?
Whiteboard: [country-gr][clientsniff][sitewait] → [country-gr][clientsniff]
Yep, nice work!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.