Closed Bug 931849 Opened 7 years ago Closed 3 years ago

real.gr doesn't redirect to mobile site on Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: alefteris, Assigned: adamopenweb)

References

()

Details

(Whiteboard: [country-gr][clientsniff][sitewait])

Attachments

(1 file)

Site: http://www.real.gr
real.gr doesn't redirect to mobile site on Firefox OS

:: Steps To Reproduce

1. Open Firefox OS browser
2. Type real.gr in Firefox OS browser

:: Expected Result

Get redirected to http://www.realmobile.gr. When typing the web site address on Firefox for Android or iOS Safari we get redirected to the mobile site.

:: Actual Result

We receive the desktop site of http://www.real.gr

:: Additional Information

Software Version: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
Device Information: Keon
Whiteboard: [country-gr]
They're using https://github.com/sebarmeli/JS-Redirection-Mobile-Site, which apparently doesn't recognize FxOS. Will need to test the latest version to make sure they don't just need to update. Otherwise let's submit a patch to the project and contact them at that point. Will file a bug for that issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr] → [country-gr][clientsniff]
Depends on: 932458
OK, we can contact them now and ask that they update to the latest version of https://github.com/sebarmeli/JS-Redirection-Mobile-Site, it's compatible with Firefox OS.
Whiteboard: [country-gr][clientsniff] → [country-gr][clientsniff][contactready]
See Also: → 931860
This website is using client side user agent detection to determine if a user is browsing using a desktop or mobile client. Unfortunately the site is not properly detecting the user agent string for mobile Firefox browsers. 

The website is using a Javascript library for detection which is outdated, updating to the latest version will resolve the problem with Firefox mobile browsers. Updated version can be found here: https://github.com/sebarmeli/JS-Redirection-Mobile-Site
The website was built by Athens Technology Center (ATC), reaching out using the site contact form: http://www.atc.gr/internal3.aspx?Page=contact
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Whiteboard: [country-gr][clientsniff][contactready] → [country-gr][clientsniff][sitewait]
ok let's see the test on AWCY said FIXED.
but testing on the device or Desktop with Fake User Agent shows it is not.

What's happening.

1. Redirection from real.gr to realmobile.gr through 
   http://www.real.gr/js/redirection_mobile.js

		// Check if the UA is a mobile one (iphone, ipod, android, blackberry)
		isUAMobile =!!(agent.match(/(iPhone|iPod|blackberry|android 0.5|htc|lg|midp|mmp|mobile|nokia|opera mini|palm|pocket|psp|sgh|smartphone|symbian|treo mini|Playstation Portable|SonyEricsson|Samsung|MobileExplorer|PalmSource|Benq|Windows Phone|Windows Mobile|IEMobile|Windows CE|Nintendo Wii)/i));

it contains the "mobile" token.


2. Reaching realmobile.gr the script is now
   http://www.realmobile.gr/javascript/redirection_mobile.js


		// Check if the UA is a mobile one (iphone, ipod, android, blackberry)
		isUAMobile =!!(agent.match(/(iPhone|iPod|blackberry|android 0.5|htc|lg|midp|mmp|mobile|nokia|opera mini|palm|pocket|psp|sgh|smartphone|symbian|treo mini|Playstation Portable|SonyEricsson|Samsung|MobileExplorer|PalmSource|Benq|Windows Phone|Windows Mobile|IEMobile|Windows CE|Nintendo Wii)/i));

This script has not been update so it goes back to real.gr and because they store the information for "not mobile", at least they avoid the ping-pong in between the two sites.

To fix it, they just need to sync their two scripts. And add the mobile token like on real.gr.
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.