Stuttering video in 1080p on Tweakers.net

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dusty-2011, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131028030205

Steps to reproduce:

I have visited http://tweakers.net/reviews/3231/sony-xperia-z-ultra-snelle-reus-met-korte-adem.html in Firefox 24 and the latest Nightly (27.0a1), and have played the video on this page. 


Actual results:

The video plays fine in resolutions up to 720p, but is extremely stuttery on the 1080p resolution. Selecting 1080p makes the entire browser very laggy and the video only shows 1 frame per second.


Expected results:

The video should play well when selecting 1080p. It plays fine on 1080p in Internet Explorer 9. I should note that the video is quite laggy in Chrome as well, but not as bad as in Firefox.
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 1

4 years ago
I have watched the video again in Chrome 30 and I must say it stutters heavily on both 720p and 1080p. The sound also stutters in Chrome 30, both at 720p and 1080p (more often in 1080p). In Firefox, the image and sound are both smooth at 720p. At 1080p, the sound is still smooth in Firefox but the image lags and stutters heavily. I only see 1 frame every 2 or 3 seconds.

In Internet Explorer 9 the video plays fine at any resolution (both the image and sound are fine). Although 720p seems slightly smoother than 1080p.

The video uses Adobe Flash. The video player is called StreamOne Videoplayer version 2013.05.29.1348.

I don't know who is to blame here. It might be a Firefox bug, a bug in Adobe Flash or a bug in the StreamOne Videoplayer.

Comment 2

4 years ago
Or poor bandwidth from the server. I'm downloading locally the MP4 video, I'm pretty sure it will play fine in 1080p.
(Reporter)

Comment 3

4 years ago
I have found out the cause of the problems in Chrome 30. In Chrome 30 the problem is not isolated to tweakers.net, it is also present on YouTube.com. Chrome 30 overloads the processor. On 720p and 1080p resolutions Chrome 30 uses 100% CPU and the audio and picture stutter. On YouTube, even 360p video peaks to 100% CPU and causes audio and picture stutters.

In Firefox 24, the problem is isolated to videos on tweakers.net. Videos on YouTube play smoothly on any resolution, with pretty low CPU usage values. On Tweakers.net however, even 360p video uses up 90% CPU.

The videos on Tweakers.net have unusually high CPU usage on any resolution for all browsers I have tested it on. Moreover, when pausing the video the CPU usage remains unusually high. Since this might not be a Firefox problem, I have also informed the site itself about these problems (in Dutch):
http://gathering.tweakers.net/forum/list_message/41127178#41127178

My processor: Intel Core 2 Duo CPU P8600 @ 2.40 GHz
Detailed CPU usage figures are below:

I have tested the processor usage in Firefox 24 with the following video:
http://tweakers.net/video/player/8411/slug.html?autoPlay=1

360p: 90% processor usage. Smooth video.
720p: 90% processor usage. Smooth video.
1080p: 90% processor usage. The picture stutters, but the sound is smooth (doesn't stutter).
When pausing the video, processor usage remains between 30% and 70%. After closing the tab, processor usage remains between 10% and 20%.

The processor usage is similar for the following videos:
http://tweakers.net/video/player/8405/slug.html?autoPlay=1
http://tweakers.net/video/player/8392/slug.html?autoPlay=1

I have tested the processor usage in Chrome 30 with the following video:
http://tweakers.net/video/player/8411/slug.html?autoPlay=1

1080p: 100% CPU. Both sound and picture stutter.
720p: 100% CPU. Both sound and picture stutter, but less severe.
360p: 96-98% CPU. The video plays smoothly.
When pausing the video (on 360p), processor usage remains between 30% and 60%. When pausing the video (on 1080p), processor usage remains between 30% and 100%. After closing the tab, processor usage remains between 10% and 20%.

I have tested the processor usage in Internet Explorer 9 with the following video:
http://tweakers.net/video/player/8411/slug.html?autoPlay=1

1080p: 70 to 85% CPU. Video plays smoothly. On lower resolutions CPU usage is similar and the video plays smoothly too.
When pausing the video(on 1080p) processor usage remains between 30 and 50%.
When pausing the video (on 360p) processor usage remains between 10 and 20%.

For comparison, CPU usage for playing a YouTube video:
http://www.youtube.com/watch?v=CevxZvSJLk8
Firefox 24, 1080p: CPU between 5% and 70%, typically around 30%. Sound and picture are both smooth.

Internet Explorer 9, 1080p: CPU between 10% and 70%, typically around 45%. Sound and picture are both smooth.
Chrome 30, 1080p: CPU between 95% and 100%. Sound and picture both stutter. Chrome 30, 720p: CPU between 90% and 100%. Sound and picture both stutter. Even on 480p resolution there are peaks to 100% CPU in Chrome 30 and the sound and picture stutter.
(Reporter)

Comment 4

4 years ago
All problems disappeared after a restart of my PC, for both Firefox and Chrome. I'm sorry for wasting anyone's time. I will mark this bug as resolved now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.