Interface 'nsIDOMGeoGeolocation', in file 'nsIDOMGeoGeolocation.idl' needs a new IID for Firefox 26

RESOLVED FIXED in Firefox 26, Firefox OS v1.2

Status

()

Core
Geolocation
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lsblakk, Assigned: bz)

Tracking

unspecified
mozilla28
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox26+ fixed, firefox27 fixed, firefox28 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Discovered when scraping mozilla-aurora 26 for changes from 25 it looks like the landing in bug 909768 should have revved the IID.  We'll need this before going to build on FF26 Beta 1 later today.
Created attachment 823554 [details] [diff] [review]
Rev the nsIDOMGeoGeolocation iid.
Attachment #823554 - Flags: review?(bugs)
Comment on attachment 823554 [details] [diff] [review]
Rev the nsIDOMGeoGeolocation iid.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 909768
User impact if declined: Some binary addons theoretically might crash.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: This is a UUID change.
Attachment #823554 - Flags: approval-mozilla-beta?
Attachment #823554 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #823554 - Flags: review?(bugs) → review+
(Reporter)

Comment 3

5 years ago
Comment on attachment 823554 [details] [diff] [review]
Rev the nsIDOMGeoGeolocation iid.

Pre-approving for uplift because we need this on Beta asap to go to build on FF26 Beta 1
Attachment #823554 - Flags: approval-mozilla-beta?
Attachment #823554 - Flags: approval-mozilla-beta+
Attachment #823554 - Flags: approval-mozilla-aurora?
Attachment #823554 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/996211c5d470
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox28: --- → fixed
Automatic merge from m-b to b2g26:
https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/8c958cfcfcd0
status-b2g-v1.2: --- → fixed

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.