Closed Bug 932034 Opened 7 years ago Closed 7 years ago

Ember.show API doesn't return can_edit property for dupe_of, blocks, and depends on fields

Categories

(bugzilla.mozilla.org :: API, defect)

Development
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: erik.bryn, Assigned: dkl)

Details

Example API response: https://bugzilla-dev.allizom.org/rest/ember/show/856410

Whether there is a current_value or not, the dupe_of field doesn't return a `can_edit` property.
Also noticed `can_edit` isn't returned for `blocks` or `depends_on`.
Summary: Ember.show API doesn't return can_edit property for dupe_of field → Ember.show API doesn't return can_edit property for dupe_of, blocks, and depends on fields
I committed changes to fix this to bugzilla-dev.allizom.org for your verification.

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2-dev
modified extensions/Ember/lib/WebService.pm
Committed revision 8594.

dkl
Flags: needinfo?(erik.bryn)
Looks good, thanks!
Flags: needinfo?(erik.bryn)
Could we prioritize getting this fix onto production as well?
Thanks. If we do a code push to prod on mon morning, this will go out then.

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2
modified extensions/Ember/lib/WebService.pm
Committed revision 9147.  

dkl
Assignee: nobody → dkl
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.