Shouldn't we be sending the "LOGOUT" command when quit Mozilla?

RESOLVED DUPLICATE of bug 115349

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 115349
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Currently I dont we send the "LOGOUT" when quiting Mozilla. Should we?

Comment 1

17 years ago
See also bug 62836...

Comment 2

17 years ago
This causes problems on my company's mailserver, because connections aren't
claused correctly on the server (TIME_WAIT etc ...)

Comment 3

17 years ago
Current dump of netstat (build 2001110903, Windows NT, only showing relevant
tcp-connections) :

Proto  Local Address          Foreign Address        State
TCP    ktpc494:1048           bemail03.net.alcatel.be:143  ESTABLISHED
TCP    ktpc494:1232           bemail03.net.alcatel.be:143  CLOSE_WAIT
TCP    ktpc494:1233           bemail03.net.alcatel.be:143  CLOSE_WAIT
TCP    ktpc494:1234           bemail03.net.alcatel.be:143  CLOSE_WAIT
TCP    ktpc494:1268           bemail03.net.alcatel.be:143  CLOSE_WAIT

At this moment, there's no mail-window open, but there's still a connection to
the imap-server bemail03 for mail-checking (the first one). But the other ones ?
I've seen them in either ESTABLISHED state or CLOSE_WAIT state, but they're
*never* cleaned up. I know that the first one is used for biff-checking, becuase
there's traffic on them every 5 minutes. The others ones stayed like this for
over an hour.

Note that as a workaround, you can close the connections by clicking the
online/offline toggle in the right corner. This seems to really close the
connections, and they're put in a TIME_WAIT state.

I've also added a comment in bug 87825 , but that bug wants to remove all
connections when the mail-window is closed.

Updated

17 years ago
Blocks: 87825

Updated

17 years ago
Summary: Shouldn't we be sending the "LOGOUT" command? → Shouldn't we be sending the "LOGOUT" command when quit Mozilla?

Updated

17 years ago
No longer blocks: 87825

Comment 4

17 years ago
I am wondering to know whether you mean "quit for whole Mozilla or not"? 

Since BEFORE I close Mozilla from browser, I got:
 
carbuncle.143        h-10-169-108-247.nscp.aoltw.net.1925  8760      0  8760    
0 ESTABLISHED                                      

AFTER I close/exit Mozilla from the browser, it has been cleaned up. 
I don't know whether you are using different IMAP server as me or not? 
( I am connecting IMAP Messaging server)
Can you retest again or provide more info here? Thanks.

Comment 5

16 years ago
see also bug 93430 for SMTP (send QUIT when connection is closed)

Comment 6

16 years ago
I'm not seeing the CLOSED_WAIT states anymore in build 2002072104 (Mozilla
1.1b). But we're not still sending the LOGOUT command.

Comment 7

16 years ago
*** Bug 166092 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: huang → gchan

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 115349 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.