Closed Bug 932203 Opened 8 years ago Closed 8 years ago

Cannot create account on Mozilla Wiki without Google and JavaScript

Categories

(Websites :: wiki.mozilla.org, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: l34nl3k4njjjjjjjjjjjj, Unassigned)

References

()

Details

Creating the account requires filling a Google captcha, which requires JavaScript. I want to avoid both Google and JavaScript.
This bug is confirmed as valid issue. Though, before I explain the steps followed, I am not sure if this is part of the design to have both Google.com and JavaScript enabled as part of the user creation. There is a definite need to have a captcha, so saying that you would like to block Google.com would mean that one needs to implement captchas in wiki.mozilla.org. Am not sure if that is possible.

Steps to recreate the issue
1. install noscript addon on the browser
2. Go to the site to create a user on wiki.mozilla.org - https://wiki.mozilla.org/index.php?title=Special:UserLogin&returnto=Main+Page
3. On NoScript addon, temporarily block both Google.com and Mozilla.org
4. The user creation page does reload fine, and there are two captcha words displayed
5. Create a user with (say) the following details 932203_test as the user, 932203_test@example.com as the email address
6. Click on create user - the user is not created, since the CAPTCHA is not complete
7. Enabling JavaScript for  mozilla.org either won't work

Though the main thing is to validate if MediaWiki has CAPTCHA support and if wiki.mozilla.org could use that without relying on Google. Turning off JS might not be a very viable option is what I would think.
Looks like there is a project to try and get this replaced https://bugzilla.mozilla.org/show_bug.cgi?id=913933. Replace Google's CAPTCHA with Microsoft Asirra
Couple of points here. Re '3. On NoScript addon, temporarily block both Google.com and Mozilla.org' I consider it unreasonable that someone wishing to use a mozilla.org site would block scripting from mozilla.org . 

Re Captcha use generally scripting usually (always?) needs to be available for their use and, as currently there is a Google one in place, it is google.com scripting which needs to be available at that point. The proposal I made in Bug 913933 I've now cancelled (for its original reason) but that would only seem to replace google with microsoft (a choice I see as redundant). 

A general note on NoScript and its ilk: every website makes decisions on how it wants to present itself to the world; what options and abilities it requires. Whilst users may desire to limit that presentation it isn't a reasonable action for a website to always reduce that presentational ability to some lowest common denominator. If a site wants to demand particular functionality (eg scripting) then it is for the user and not the site to make the decision whether that user accesses the site. wiki.m.o is no different in this regard.

Mediawiki has hooks to add various captcha services and, should it be decided that Google's is no longer acceptable (which it clearly is at the moment and there are no plans to change that) then alternatives can be looked at.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Thanks for the clarification Alison. And regarding the NoScript plugin, I used that as an easy way to try and recreate the issue reported. Another way would have been to disable JS everywhere, though, using NoScript was an easier way. Further to this, is it possible that we mention that JS has to be enabled and Google.com should be accessible to be able to create an account on this page - https://wiki.mozilla.org/index.php?title=Special:UserLogin&returnto=Main+Page. Right now, the only mention is to have cookies enabled. That way, access to Google becomes a pre-req

Thank you
You need to log in before you can comment on or make changes to this bug.