External apps split in two folders during make process

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: albert, Assigned: albert)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe][qa-])

Attachments

(1 attachment)

363 bytes, text/html
yurenju
: review+
Details
(Assignee)

Description

5 years ago
External apps are split in two folders during make gaia process.

For a given application 'app' two folders are generated in webapps/profile:
'app' and 'app.gaiamobile.org'
(Assignee)

Updated

5 years ago
Blocks: 929602
Whiteboard: [systemsfe]
(Assignee)

Updated

5 years ago
Assignee: nobody → acperez
(Assignee)

Comment 1

5 years ago
Created attachment 824050 [details]
Patch
Attachment #824050 - Flags: review?(yurenju.mozilla)
Albert, do you know the root cause? looks we will have two times to generate zip file for same app.
Flags: needinfo?(acperez)
(Assignee)

Comment 3

5 years ago
For external apps, webapp-manifests.js copies data to 'sourceDirectoryName' (f.e. gamepack) and then, webapp-zip.js generates the zip in 'domain' (gamepack.gaiamobile.org). The result is profile contains both folders.

External apps doesn't need to generate the zip, so patch copies data in webapp-manifests.js and does nothing in webapp-zip.js
Flags: needinfo?(acperez)
ni? Fabrice for question on github[1]

[1] https://github.com/mozilla-b2g/gaia/pull/13185/files#r7393351
Flags: needinfo?(fabrice)
Sorry I didn't see that you pinged me on github. The metadata.json is not needed in the shipped profile. It's only used to set correct values in webapps.json for the app.
Flags: needinfo?(fabrice)
Comment on attachment 824050 [details]
Patch

Thank you Fabrice!

and r=yurenju if comments on github are addressed.
Attachment #824050 - Flags: review?(yurenju.mozilla) → review+
(Assignee)

Comment 7

5 years ago
Master: https://github.com/mozilla-b2g/gaia/commit/31687ef383bc1b85a9d388fb3dde610ab7e8f8fd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe] → [systemsfe][qa-]
You need to log in before you can comment on or make changes to this bug.