Update Code to Latest ICU 52.1

RESOLVED DUPLICATE of bug 924839

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 924839
5 years ago
5 years ago

People

(Reporter: robert.rcampbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155223

Steps to reproduce:

Go to any Lao website, such as laosabbathschool.com. Lao text keeps going on and on until there is a space (Lao does not use spaces as word delimeters, but similar to punctuation.)


Actual results:

Lao text does not wrap. It doesn't know where to split the text. 


Expected results:

Lao text should split words like the ICU 52.1 system now can do... (This is very similar to Thai / Khmer word wrapping / boundary analysis.)

Can you all update Firefox to include the latest ICU 52.1? I am running Ubuntu, so I would think it would notice my locally installed ICU, but it doesn't. Also, there are loads of Windows and Mac systems that could benefit from this code as well.
(Reporter)

Updated

5 years ago
OS: Linux → All
Hardware: x86_64 → All

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924839
You need to log in before you can comment on or make changes to this bug.