Implement ES6 Object.assign and Object.mixin

RESOLVED DUPLICATE of bug 937855

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 937855
5 years ago
5 years ago

People

(Reporter: benvie, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
ES6 draft spec (October 2013 revision):

* Object.assign (target, source) - 19.1.2.1
  Copies the values of all of the enumerable own properties from a source to a target. Uses [[Get]] on the source and [[Put]] on the target, so will invoke getters/setters.

* Object.mixin (target, source) - 19.1.2.15
  Copies the definitions of all of the own properties from a source to a target. Supports rebinding of `super` which we can ignore until we support classes.

Comment 1

5 years ago
I think this bug should be splited to implementaion of Object.assign and implementation of Object.mixin .
Because implementing Object.assign is easy but Object.mixin is difficult and it depending on something related to "super" mechanism
(Reporter)

Updated

5 years ago
Depends on: 937855
Keywords: dev-doc-needed
Given comment 2, this is a straight dupe of bug 937855.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937855
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.