Rooting analysis needs to know about new PersistentRooted type

RESOLVED DUPLICATE of bug 957891

Status

()

RESOLVED DUPLICATE of bug 957891
5 years ago
3 years ago

People

(Reporter: jimb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Bug 892643 adds a new root type, PersistentRooted. It is okay to have a PersistentRooted on the stack across a GC. The rooting analysis needs to be updated before we can land any uses of PersistentRooted.
I'm guessing that this got resolved somehow, given that PersistentRooted has landed?
Flags: needinfo?(sphink)
Flags: needinfo?(jimb)
(Reporter)

Comment 2

3 years ago
I, at least, don't know of any reason this bug needs to be kept open. I think it was filed mostly for Steve's benefit.
Flags: needinfo?(jimb)
Sorry, I really need to get a handle on my needinfos. I'm ignoring some straightforward ones like this because my queue is cluttered up with ancient really hard ones that I should track some other way.

annotations.js has this:

    return name.startsWith('Rooted') || name.startsWith('PersistentRooted');

so this is done. In fact, this bug is a dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sphink)
Resolution: --- → DUPLICATE
Duplicate of bug: 957891
You need to log in before you can comment on or make changes to this bug.