Firefox 24.1esr is not fully localized in many (all?) locales

RESOLVED DUPLICATE of bug 932310

Status

Mozilla Localizations
fr / French
--
critical
RESOLVED DUPLICATE of bug 932310
5 years ago
5 years ago

People

(Reporter: TTOO, Assigned: Bugzilla FR)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 824200 [details]
Sans titre.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20131021230807

Steps to reproduce:

I upgraded firefox 24.0esr to firefox 24.1esr (either with automatic update & manually from website)


Actual results:

Some translation are missing (option menu, few windows boxes. etc...)


Expected results:

My expectation : firefox fully localized like firefox 24.0esr was (or firefox 25.0 I checked)
(Reporter)

Updated

5 years ago
Summary: French translation are partially missing (firefox 24.0esr -> 24.1esr) → French translation is partially missing (firefox 24.0esr -> 24.1esr)
Wow, that looks weird because l10n sign-off have been correctly done for Firefox 24.0 and l10n is not supposed to change between 24.0 and 24.1.

I'm downloading the latest build from http://www.mozilla.org/en-US/firefox/organizations/all.html to confirm.
Tested on Linux 64 with this build http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/24.1.0esr/linux-x86_64/fr/ and the Data Choices panel in _not_ localized in French.

Pike, what could have been done wrong here? Sign-off have been done for 24 early on the Aurora cycle.

TTOO said 24.0esr and 25 are fine (I'll check to be sure since this is a critical issue), so I can't explain that. Is this a bug on Firefox ESR itself?
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(l10n)
(Reporter)

Comment 3

5 years ago
I tried with spanish version from http://www.mozilla.org/en-US/firefox/organizations/all.html and there is the same issue. So I guess every fully localized languages are affected by this issue?
(In reply to TTOO from comment #3)
> I tried with spanish version from
> http://www.mozilla.org/en-US/firefox/organizations/all.html and there is the
> same issue. So I guess every fully localized languages are affected by this
> issue?

Looks like it, indeed. My guess is that the wrong sign-off has been used for this build, for all locales. Maybe FirefoxESR 17.0 sign-off, that could explain the huge amount of missing strings.

CC'ing some RelEng people
Summary: French translation is partially missing (firefox 24.0esr -> 24.1esr) → Firefox 24.1esr is not fully localized in many (all?) locales
Definitely bug 932310.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(l10n)
Resolution: --- → DUPLICATE
Summary: Firefox 24.1esr is not fully localized in many (all?) locales → French translation is partially missing (firefox 24.0esr -> 24.1esr)
Duplicate of bug: 932310
Restoring updated subject.
Summary: French translation is partially missing (firefox 24.0esr -> 24.1esr) → Firefox 24.1esr is not fully localized in many (all?) locales
You need to log in before you can comment on or make changes to this bug.