Firefox 25 not loading oracle convergence webmail login page correctly

VERIFIED FIXED in Firefox 26

Status

()

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: philip.ludwig, Assigned: bzbarsky)

Tracking

({dev-doc-complete, regression, site-compat})

25 Branch
mozilla28
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox25 wontfix, firefox26+ verified, firefox27+ verified, firefox28 verified, b2g-v1.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

Upgraded to Windows Desktop Release Firefox 25.0 from Release 24.0.
Upgraded to Android Firefox 25.0 from 24.0.
Our Oracle Convergence Webmail server login page no longer allows users to log into email system. http://mail1.griffithscorp.com
Site works correctly with 24.0 and prior both Windows and Android.


Actual results:

Missing sign in button.  Also after entering username and password then just pressing enter nothing happens.
Also missing some graphics and text on page.


Expected results:

Sign in button available.  Typing username and password and press enter key also allows login.
Shows missing graphics and copyright text.
Interesting, the same issue seems to exist in Chrome, as well as in Firefox 25. In Safari I can see the login button and copyright text, but get a warning message that Oracle Convergence is not supported in the browser.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 2

6 years ago
Regression window about "no login button"

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/7c20e8e4e56e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130723 Firefox/25.0 ID:20130723131343
Bad:
http://hg.mozilla.org/mozilla-central/rev/2983ca6d4d1a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130723 Firefox/25.0 ID:20130723173844
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7c20e8e4e56e&tochange=2983ca6d4d1a


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c4d279b10128
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130723 Firefox/25.0 ID:20130723064847
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3c811f1e3d12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130723 Firefox/25.0 ID:20130723071046
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c4d279b10128&tochange=3c811f1e3d12
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core

Updated

6 years ago
Blocks: 895974

Comment 3

6 years ago
An error in Error Console:

Error: TypeError: node.getAttribute is not a function
Source File: http://mail1.griffithscorp.com/iwc_static/js/dojotoolkit/dojo/dojo.js?00.01_194502
Line: 315
That's basically the same issue as bug 901632: a broken version of dojo, right?

Our options are as in bug 901632 comment 8, I believe. Either the site gets fixed (sounds like this would need deployment across all the webmail things involved, actually) or we drop nextElementSibling from DocumentType and get the spec changed accordingly.  Unfortunately, it looks like this never got raised as a spec issue?  I thought I'd done that...

philip, out of curiousity, does this site work in a current Chrome?
Flags: needinfo?(annevk)
Ah, comment 1 says it does not; sounds like they've already shipped this too.

The other question I have is whether the broken dojo version is an inherent property of Oracle Convergence Webmail or just this one instance of it.
Flags: needinfo?(philip.ludwig)

Comment 6

6 years ago
I cannot find a specification issue.

http://software.hixie.ch/utilities/js/live-dom-viewer/
<!DOCTYPE html><script>w(document.firstChild.nextElementSibling)</script>

gives the root element for me in Chrome and Firefox. Safari and IE10 give undefined.
Flags: needinfo?(annevk)
Reporter

Comment 7

6 years ago
Site fails in current Chrome also.  This is a default install of Oracle Convergence Webmail, a Google search indicated others with the same log on issue.
Flags: needinfo?(philip.ludwig)

Comment 8

6 years ago
I'm on Chrome's dev channel... Found https://code.google.com/p/chromium/issues/detail?id=246609 again. Having a case of deja vu.
Anne: right, the broken versions of dojo depend on typeof(DocumentType.nextElementSibling) == "undefined" testing true.

I suspect we should drop nextElementSibling from DocumentType, unless we think we can get all the Oracle Convergence Webmail installs updated.  :(

Comment 11

6 years ago
This change conflicts with some of the applications we support.  This is not just about updating a single website - it's about applications that have shipped versions of dojo that are incompatible with this change. While all applications should update the version of dojo to correct this issue it will take these products and customers time to upgrade and it therefore makes firefox 25 incompatible with our applications.  With customer using automatic updates this is a problem for them and it would be great if you could consider reverting this change in FF26 and then having a plan to reintroduce it in the coming months after there have been a few months for customers to address this.
Andrew, I suspect we're going to have to change the spec to work around the dojo brokenness here....

Anne, what exactly is the spec story here?  Andrew is right, imo, that we need to pull this from 26 one way or the other.
Flags: needinfo?(annevk)

Comment 13

6 years ago
So I don't understand how this is not an issue with Chrome but is with Firefox. Isn't Chrome doing the same? Given what arv said with regards to Chrome I was not planning on changing the specification.
Flags: needinfo?(annevk)
> So I don't understand how this is not an issue with Chrome 

It is.  See comment 1.  They might be willing to break stuff willy nilly like this (though I doubt it; chances are it's just that no one has reported a bug to them about this yet), but I'm not.  So I plan to fix this in Gecko; the only question is which parts I remove from where.  That's where the spec bits come in.  nextElementSibling on DocumentType definitely needs to go away.  What about previousElementSibling?
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Andrew, if I created a test build for you with that patch, could you test it?  Which OS would you like it for?
Whiteboard: [need review]
Attachment #831979 - Flags: review?(bugs) → review+

Comment 17

6 years ago
I know it does not fix anything but when I googled "oracle convergence mail firefox login button", this bug report came in first place, for the people waiting for a fix from either side(firefox or oracle), you can create and use a javascript bookmaklet to login after you enter your login information.Such as:

javascript:login();

Comment 18

6 years ago
(In reply to Boris Zbarsky [:bz] from comment #16)
> Andrew, if I created a test build for you with that patch, could you test
> it?  Which OS would you like it for?

Hello Boris, yes, I can test. Windows 7 if it's easy for you.  Thanks, Andrew

Comment 20

6 years ago
Hello Boris, I tested this build and it resolved all issues with our application!  Thanks!
Excellent.  :)
Reporter

Comment 22

6 years ago
I also tested this build and it resolved the issues with the original bug report page (Oracle Convergence log in page).  Thanks!
ms2ger, just fyi I'm going to adjust dom/imptests/html/dom/test_interfaces.html to reflect reality.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7a33656ad047
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla28
Actually, no, we still need a test here.  :(
Flags: in-testsuite+ → in-testsuite?
Comment on attachment 831979 [details] [diff] [review]
Drop nextElementSibling/previousElementSibling from DocumentType.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 895974 
User impact if declined: Various web apps broken in Firefox.
Testing completed (on m-c, etc.): Passes regression tests and manual testing by
   people who could reproduce the problem.
Risk to taking this patch (and alternatives if risky): I believe this is very low
   risk; it just partially backs out bug 895974.
String or IDL/UUID changes made by this patch: None.
Attachment #831979 - Flags: approval-mozilla-beta?
Attachment #831979 - Flags: approval-mozilla-aurora?
Attachment #833393 - Flags: approval-mozilla-beta?
Attachment #833393 - Flags: approval-mozilla-aurora?
Attachment #831979 - Attachment is obsolete: true
Attachment #831979 - Flags: approval-mozilla-beta?
Attachment #831979 - Flags: approval-mozilla-aurora?
Thanks for the heads-up. I fixed the spec and sent a PR for the upstream tests.
https://hg.mozilla.org/mozilla-central/rev/7a33656ad047
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #833393 - Flags: approval-mozilla-beta?
Attachment #833393 - Flags: approval-mozilla-beta+
Attachment #833393 - Flags: approval-mozilla-aurora?
Attachment #833393 - Flags: approval-mozilla-aurora+

Comment 32

6 years ago
Hello- my customer is experiencing a similar issue with their site.
Can you summarize how to fix.  Can we patch dojo on our server?
Is version 25 getting updated? or a future version?
> Can we patch dojo on our server?

Yes.  See https://bugzilla.mozilla.org/show_bug.cgi?id=901632#c6 for the relevant broken dojo code and https://bugzilla.mozilla.org/show_bug.cgi?id=901632#c7 for the fix for it.  Or update dojo to a recent version, of course.

> Is version 25 getting updated?

No.

> or a future version?

Firefox 26 will have a workaround for this dojo problem, yes.

Comment 34

6 years ago
OK, so to summarize the c6 and c7 that you referenced:

Change:
var te, x = 0, tret = root[_1bc];
to:
var te, x = 0, tret = root.children || root.childNodes;

Correct?

The forum discussion for Chrome references a github diff that shows this specific change plus some other things:
https://github.com/dojo/dojo/commit/fc262d0d589c490cdd671791f1546a4665ed69c6

Are these other changes needed as well?
Probably best to have the other changes there too, yes.
Philip, can you please confirm this is fixed in Firefox 26, 27, and 28?
Flags: needinfo?(philip.ludwig)
Reporter

Comment 37

6 years ago
I can confirm that it is fixed in Firefox 26 and 27, have not downloaded or tried 28.
Flags: needinfo?(philip.ludwig)
(In reply to philip.ludwig from comment #37)
> I can confirm that it is fixed in Firefox 26 and 27, have not downloaded or
> tried 28.

Will you be able to download and verify Firefox 28 soon? You can get it from http://aurora.mozilla.org.
Flags: needinfo?(philip.ludwig)
Reporter

Comment 39

6 years ago
I downloaded and verified that our web page loads in Aurora 28.0a2
Flags: needinfo?(philip.ludwig)
(In reply to philip.ludwig from comment #39)
> I downloaded and verified that our web page loads in Aurora 28.0a2

Thanks!
Status: RESOLVED → VERIFIED
(In reply to Boris Zbarsky [:bz] from comment #25)
> Actually, no, we still need a test here.  :(

Is that test still needed? If so, can you please advise about what it's supposed to do?
Thank you!
Probably just test that DocumentType has no nextElementSibling/previousElementSibling attributes.
(Their are interface changes that I want to reflect in the doc, hence the dev-doc-needed)
Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.