Last Comment Bug 93281 - server-push jpeg (doit.c)
: server-push jpeg (doit.c)
Status: RESOLVED DUPLICATE of bug 76776
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86 Windows NT
: -- enhancement (vote)
: ---
Assigned To: Stuart Parmenter
: Terri Preston
:
Mentors:
http://jupiter.math.msu.su/~mnn/jpeg.htm
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 10:50 PDT by Artem Saveliev
Modified: 2001-09-05 08:33 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Artem Saveliev 2001-08-02 10:50:16 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

There seems to be original functionality in Netscape (3 and 4 at least) that
allows you to post images using script in some sort of stream.
This software:
http://www-vs.informatik.uni-ulm.de/soft/wv/webvideo.html
is used here:
http://jupiter.math.msu.su/~mnn/jpeg.htm
To "stream" "video" from a webcam

Reproducible: Always
Steps to Reproduce:
1. Go to http://jupiter.math.msu.su/~mnn/jpeg.htm
2. Using Mozilla and Internet Explorer you get nothing
3. Using Netscape Communicator 4 and Netscape Navigator 3 you see image changing.

Actual Results:  Don't see anything

Expected Results:  See the stream

http://jupiter.math.msu.su/~mnn/jpeg.htm
http://www-vs.informatik.uni-ulm.de/soft/wv/webvideo.html
Comment 1 RC 2001-08-02 12:38:35 PDT
WFM on WinNT 4 2001080203

You may have to wait a while for the streaming image to come up.
Please try a later build from http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Comment 2 Artem Saveliev 2001-08-02 13:08:51 PDT
Using 2001080203
The original URL:
http://jupiter.math.msu.su/~mnn/jpeg.htm
doesn't show image at all.
You should try Netscape 4 to see what I mean, because there is also a Java
scroll on the top - that's not what I meant.
Comment 3 Alfonso Martinez 2001-08-02 13:40:43 PDT
WFM win98 build 2001080120.
I can see the same images in both NS 4.7 and Mozilla: 
two banners at the top, and below them a big webcam image that it is updated
once a minute.
The difference is that in NS the throbber and status bar keep on showing that
something is downloaded, but in mozilla they stop after the initial image is shown.
Comment 4 Keyser Sose 2001-09-04 18:57:13 PDT

*** This bug has been marked as a duplicate of 76776 ***
Comment 5 Daniel Mario Vega (Restore MNG Support --> #18574) 2001-09-05 06:54:21 PDT
I really cant verify this bug. Nav4.x and Mozilla shows the same to me. But I
think  76776 is about a different problem. Bug 76776 is about "progressive JPEGs". 

(see http://www.faqs.org/faqs/jpeg-faq/part1/section-11.html )

This bug is about "Server PUSH". Server PUSH is about streaming multiple content
on a HTTP response

(see http://home.netscape.com/assist/net_sites/pushpull.html )
Comment 6 Artem Saveliev 2001-09-05 08:33:05 PDT
I can now confirm (after fixing my setup) that I do see the desired result (at 
least sometimes). Sorry about that.
Problem is that I can only do that once per stream. Second time I go to that 
page, or just try to reload it, nothing shows up. I can go to another stream and 
it will work, but again, only once.

Also, when I try to close Mozilla after that (to try again) it sometimes 
crashes. That only seems to be that case with Java enabled, so it is probably 
another bug (I use JRE 1.3.0_01)

Here are URLs that I used in last test
http://rr-vs.informatik.uni-ulm.de/rr/gui2/gui.head.html
http://rr-vs.informatik.uni-ulm.de/rr/OtherView.html

Note You need to log in before you can comment on or make changes to this bug.