Click to play overlay not showing for Google Hangout plugin

VERIFIED FIXED in mozilla29

Status

()

Core
Plug-ins
P3
normal
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: VarCat, Assigned: Benjamin Smedberg)

Tracking

(Depends on: 1 bug)

26 Branch
mozilla29
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox26 ?)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Environment:
Build identifier: Mozilla/5.0 (Windows NT 6.3; rv:26.0) Gecko/20100101 Firefox/26.0
Build Id: 20131028225529
OS: Windows 8.1 Pro Preview x86

Steps to reproduce:

1. Be sure that parameter value for plugins.click_to_play is true.
2. Install google hangouts plugin.
3. Login to google plus.
3. Click on the Start a Party button.

Expected:
Click to play overlay announces that Google Talk plugin should be allowed.

Actual:
The only announcement that a plug-in is needed is the fact that the doorhanger is blue.
(Reporter)

Updated

5 years ago
Blocks: 738698
See Also: → bug 756206
Summary: Click to play overlay not showing for Google Talk plugin. → Click to play overlay not showing for Google Hangout plugin

Updated

5 years ago
status-firefox26: --- → ?
(Assignee)

Comment 1

5 years ago
This appears to show the location bar icon correctly now (on trunk and it should also work in beta3). I've been in contact with the google talk/hangouts teams, but I think we should be ok with the infobar for discoverability.

Plugin details:

Google Talk Plugin Video Accelerator

    File: npgtpo3dautoplugin.dll
    Path: C:\Users\bsmedberg\AppData\Roaming\Mozilla\plugins\npgtpo3dautoplugin.dll
    Version: 0.1.44.29
    State: Enabled
    Google Talk Plugin Video Accelerator version:0.1.44.29

MIME Type	Description	Suffixes
application/vnd.gtpo3d.auto		
Google Talk Plugin Video Renderer

    File: npo1d.dll
    Path: C:\Users\bsmedberg\AppData\Roaming\Mozilla\plugins\npo1d.dll
    Version: 4.8.2.15856
    State: Enabled
    Version 4.8.2.15856

MIME Type	Description	Suffixes
application/o1d	Google Talk Plugin Video Renderer	o1d
Google Talk Plugin

    File: npgoogletalk.dll
    Path: C:\Users\bsmedberg\AppData\Roaming\Mozilla\plugins\npgoogletalk.dll
    Version: 4.8.2.15856
    State: Enabled
    Version 4.8.2.15856

MIME Type	Description	Suffixes
application/googletalk	Google voice and video chat	googletalk
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
This is what happens now here, FF 28.0a1 (2013-11-25):
1. Open https://plus.google.com/ -> the notification bar appears
2. Choosing "Allow"
3. Click on the "Start a Party" button on the right bottom of the page -> a new pop-up shows up, no CTP notification bar (expected because it's on the same domain)
4. Cancel the invitation message -> now the video call should be started in the pop-up, but it isn't
5. Click the CTP doorhanger -> Google Talk is allowed, Google Talk Video Render is blocked
6. Allow Google Talk Video Render too
7. Only after reload the camera starts

So, the problem would be that second plugin that starts only in the pop-up.
Please reopen if you think so.
Flags: needinfo?(benjamin)
(Assignee)

Comment 3

5 years ago
I debugged this locally and the plugin is technically visible: hangouts has just moved it offscreen by positioning it at -10000,-10000. Bug 853973 might fix this, or else we can add a check for on-screen, but I'm not sure how many more workarounds are worthwhile.
Status: RESOLVED → REOPENED
Flags: needinfo?(benjamin)
Priority: -- → P3
Resolution: WORKSFORME → ---
(Assignee)

Comment 4

5 years ago
Created attachment 8345416 [details] [diff] [review]
click-to-play not discoverable for Google Hangouts video plugin because it is positioned at -40000,-40000. Check for positioning and treat this as a hidden plugin
Attachment #8345416 - Flags: review?(jaws)
(Assignee)

Updated

5 years ago
Assignee: nobody → benjamin
Status: REOPENED → ASSIGNED
Comment on attachment 8345416 [details] [diff] [review]
click-to-play not discoverable for Google Hangouts video plugin because it is positioned at -40000,-40000. Check for positioning and treat this as a hidden plugin

Review of attachment 8345416 [details] [diff] [review]:
-----------------------------------------------------------------

r=me but I have requested changes to this underlying code in bug 853973.
Attachment #8345416 - Flags: review?(jaws) → review+
(Assignee)

Comment 6

5 years ago
Created attachment 8347432 [details] [diff] [review]
Rebased patch.
Attachment #8345416 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/0be09b045302
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
I confirm that Google Hangout works now if allowing both google plugins from the 2 windows that show up. Verified FF 29.0a1 (2013-12-18) Win 7, Mac OS X 10.9, Ubuntu 12.04
Status: RESOLVED → VERIFIED
OS: Windows 8.1 → All
Hardware: x86 → All
Note: At some point a google tooltip appears saying: "Select 'Allow' for both Google Talk plugins in order to access the video call. See detailed instructions" which links here https://support.google.com/hangouts/answer/3110347?p=plugin&rd=1. The Firefox instructions are not really up to date (2. there is no blue icon, 3. don't know what this is about)

Updated

2 years ago
Depends on: 1328048
You need to log in before you can comment on or make changes to this bug.