Page load fails on kunagi.org

VERIFIED FIXED in Firefox 27

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: alice0775, Assigned: bhackett)

Tracking

({regression})

27 Branch
mozilla28
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27- verified, firefox28- verified)

Details

()

Attachments

(2 attachments)

Posted file Unexpected_Error
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/829d7bef8b0a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131030030201

Steps To Reproduce:
1. Open http://kunagi.org/
2. Click "Start Demo" orange button
3. Type Username:demo password:demo in "Login with Password" section
4. Click "Login" button

5. Click Sprint at the left side menu
6. Click Product at the left side menu

7. Repeat frop step.1 if not reproduce the problem

Actual Reuslts:
	
Unexpected Error
AttachDetachException: Exception caught: 2 exceptions caught: Exception caught: (TypeError)
...

Detail, see Attached

In Web Consore:
01:32:05.285 "Thu Oct 31 01:32:05 GMT+900 2013 
    ERROR ScrumGwtApplication  Unexpected error 
com.google.gwt.event.shared.UmbrellaException: Exception caught: Exception caught: 2 exceptions caught: Exception caught: (TypeError) 
 stack: qxb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5170
Owb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5560
uwb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5191
Ewb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5560
txb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5560
qxb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:5170
Owb@https://servisto.de/kunagi-demo/scrum.ScrumGwtApplication/84D7DACDBE38EB45384B6270FC1835F1.cache.html:55"[…] 84D7DACDBE38EB45384B6270FC1835F1.cache.html:3522



Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/1a2d9a04ffb2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130927090306
Bad:
http://hg.mozilla.org/mozilla-central/rev/e1914e294152
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130927191437
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1a2d9a04ffb2&tochange=e1914e294152


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/19af7baaf26e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130927102235
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3f8e57e07eee
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130927103035
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=19af7baaf26e&tochange=3f8e57e07eee

regressed by:
3f8e57e07eee	Brian Hackett — Bug 920689 - Only include types for 'own' properties in heap type sets, r=jandem.
s/frop/from/
bhackett,

Can you look into this and also let us know what kind of impact this would have?
Flags: needinfo?(bhackett1024)
Specifically, whether this will be an issue impacting many websites. Thanks for following up on this Benjamin!
I get 'Login failed' at step 3.
Hi Alice, any tips for Brian?
Flags: needinfo?(alice0775)
OK, the following STR may helps.

Steps To Reproduce:
1. Open http://kunagi.org/
2. Click "Start Demo" orange button
3. Click "Create new account" link

4. Type Username:xxxx password:yyyy    (xxxx,yyyy: any unique word)
5. Click "Create account" button

6. Click "Create Example Project" button at the top-right
7. Click "Open Project" button

8. Click all "Sprint" "Produce" "Project" "Collaboration" "Settings" "Dashboard" link at the left side menu

9. Repeat Step#8 if not reproduce the problem
Flags: needinfo?(alice0775)
Posted patch patchSplinter Review
This fixes the error for me.  This took a while to track down but the problem seems to be that the logic in annotateGetPropertyCache was messed up by bug 920689 (though it wasn't quite right before either, for objects where the called property is missing or is fetched from a proxy etc.).  This patch consolidates the logic with that of testSingletonProperty, which is essentially doing the same thing.
Assignee: nobody → bhackett1024
Attachment #828397 - Flags: review?(jdemooij)
Flags: needinfo?(bhackett1024)
Comment on attachment 828397 [details] [diff] [review]
patch

Review of attachment 828397 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.

::: js/src/jit/IonBuilder.cpp
@@ +6066,5 @@
>          *testObject = (obj->type() != MIRType_Object);
>          return true;
>        }
>        default:
>          return true;

Pre-existing, but this should be |return false;| I think.
Attachment #828397 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/7a132dd10730
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
This looks like a good patch to uplift (on aurora) but assuming this may not impact of lot of websites, no need to track.
Comment on attachment 828397 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 920689
User impact if declined: broken websites
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
Attachment #828397 - Flags: approval-mozilla-aurora?
Attachment #828397 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Doesn't apply cleanly due to bug 930048 not being on Aurora. Please provide a branch-specific patch or nominate that for uplift.
Flags: needinfo?(bhackett1024)
Keywords: verifyme
I can't reproduce this issue, after following the STR from comment 6, with the Nightly 32-bit build from 2013-09-27, build ID: 20130927030202.

Any thoughts/suggestions? Thanks!
Flags: needinfo?(alice0775)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #15)
> I can't reproduce this issue, after following the STR from comment 6, with
> the Nightly 32-bit build from 2013-09-27, build ID: 20130927030202.
> 
> Any thoughts/suggestions? Thanks!

You should try 2013-09-28 nightly Nightly build
Flags: needinfo?(alice0775)
> You should try 2013-09-28 nightly Nightly build

Indeed, with the Nightly from that date, the issue is reproducible.

Verified as fixed on Win 7 64-bit, with both latest Nightly & Aurora builds.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: manuela.muntean
Depends on: 945294
You need to log in before you can comment on or make changes to this bug.