Closed Bug 932969 Opened 6 years ago Closed 6 years ago

Find bar string is "undefined" upon first invocation

Categories

(SeaMonkey :: Find In Page, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.25

People

(Reporter: InvisibleSmiley, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR: Hit Ctrl+F in recent SM trunk build

Result: "undefined"

Expected: "" (empty string) / "Find in page" placeholder text
Probably due to the refactoring by Firefox developers when making one findbar per tab instead of sharing one findbar per tabbrowser.
Duplicate of this bug: 933227
Attached patch Proposed patchSplinter Review
Attachment #825453 - Flags: review?
Stupid Bugzilla.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Comment on attachment 825453 [details] [diff] [review]
Proposed patch

Bug 916477 overlooked an subtle part of the finder code. Because we share the findbar between all the tabs we also need the last search cache fields defined on the tabbrowser rather than the browser.

If you don't want to do the review and Ratty hasn't finished rebuilding his laptop yet then feel free to punt it to IanN or someone.
Attachment #825453 - Flags: review? → review?(jh)
Setting reminder to myself
If needed: rs=me from code inspection.
Flags: needinfo?(philip.chee)
Comment on attachment 825453 [details] [diff] [review]
Proposed patch

FTR: I actually tried and analyzed this. Thanks Ratty anyway, maybe another time I'll accept your offer. :-)
Attachment #825453 - Flags: review?(jh) → review+
Neil, are you waiting for the tree to reopen or can this land?
Comment on attachment 825453 [details] [diff] [review]
Proposed patch

This patch works for me.
Attachment #825453 - Flags: feedback+
Pushed comm-central changeset ff1d24951bcc.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.25
Flags: needinfo?(philip.chee)
Flags: needinfo?(philip.chee)
You need to log in before you can comment on or make changes to this bug.