Closed Bug 93299 Opened 18 years ago Closed 17 years ago

WRMB: Layout problems in mfcembed

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmkobayashi, Assigned: rogerl)

References

()

Details

(Whiteboard: [bugscape: 7939])

Attachments

(2 files)

1. red bar at top (beneath grey buttons)text field and quick trace button are 
both out of alignment (they both hang off the red bar a bit, see IE or NS 6.1 
for proper formatting). 

2. "Latest Customer Service Indicators" has a scrolling ticker to the right of 
it (see IE or NS6.1) This is not visible at all (well, a black bar is visible, 
no ticker text)

3. Text overlapping images in mfcembed differently than in NS6.1/IE on side 
frame (tracking / tracing, shipping tools etc, on left hand side) 

4. On a reload, the grey background on the side frame does not load. 

Does not occur in 6.1, occurs in mfcembed (8/1 build)
Keywords: topembed
Summary: Layout problems in mfcembed → Layout problems in mfcembed
QA Contact: mdunn → jmkobayashi
Not an embedding problem, appears in 2001080408 Mozilla build.  Reassigning.
Assignee: adamlock → karnaze
Status: UNCONFIRMED → NEW
Component: Embedding APIs → Layout
Ever confirmed: true
QA Contact: jmkobayashi → petersen
petersen, chrisd, jmkobayashi,

I thought you were going to break this topembed bug into multiple pieces and 
develop test cases. thanks.
Tested on Netscape6.1 (08_13_05_trunk) and 'mfcembed' (08_13_05_trunk). Problems 
are NOT evident in Netscape 6.1 but ARE evident in 'mfcembed'. Breaking down 
page to isolate problems.
Additional comments to above. Tested on Win98 and Win2000. There is a small 
difference between the two with Netscape 6.1 but the major problems are in 
'mfcembed'. Continuing to break down.
Results of testing on Win98 with 8_13_05_trunk 'mfcembed' and 
08_13_05_trunk Netscape6.1 builds:

Issue #1:
alignment problems have to do with positioning of z-index layers in 'mfcembed'. 
Attached are testcases - the first was saved in 'mfcembed'; the second was saved 
in Netscape 6.1. If you open up the netscape saved file in 'mfcembed', it 
renders correctly. If you open up the 'mfcembed' saved file in 'mfcembed' you 
get the problems described in this first issue. It looks like 'mfcembed' is not 
positioning correctly.

Issues #2 & 3: 
Not sure about this, but I think these problems are due Javascript not rendering 
correctly. Does Javascript work in 'mfcembed'?

Issue #4:
Could not reproduce 
QA Contact: petersen → chrisd
Attached file file saved in Netscape
Disregard the attachments above - too many images to include. Go to:
 
http://bubblegum/chrisd/saia/embed_rev.html (saved in 'mfcembed')
http://bubblegum/chrisd/saia/netscape_rev.html (saved in Netscape6.1)

If this is not sufficient, please request a zipped file.
Summary: Layout problems in mfcembed → WRMB: Layout problems in mfcembed
beard, can you take a look at this due to issues #2 and #3. I doubt it is a 
layout issue since it renders ok in mozilla.
Assignee: karnaze → beard
Please clarify, what does it mean for javascript to render? Do you mean that
<SCRIPT> tags aren't working? I will have to reassign this to somebody who can
run MFCEmbed.
Assignee: beard → rogerl
av, any chance you can look at this? and can anyone answer beard's Q?
I am looking into this again. Will test in current 'mfcembed'
adding bugscape ref
Whiteboard: [bugscape: 7939]
Blocks: 64833
removing topembed
Keywords: topembed
Just looked at this in MFCEmbed nightly build Feb. 20, 2002 on Win2K. 

#1 looks fine

#2 is a java issue. It works fine in a browser that loads Java applets (tested
with K-Meleon 0.6)

#3 not seeing this. The layout issue must have been corrected.

#4 not seeing this either.

Looks like this was can be closed as the Java "problem" is unrelated to the
layout bug reported and also works as long as the browser loads the JRE.
removing myself from the cc list
Changing QA contact
QA Contact: chrisd → petersen
WFM per comment #15.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.