Scratch "undo" and "redo" menus are completely broken

VERIFIED FIXED in Firefox 27

Status

P1
normal
VERIFIED FIXED
5 years ago
2 months ago

People

(Reporter: bbenvie, Assigned: anton)

Tracking

Trunk
Firefox 28

Firefox Tracking Flags

(firefox25 unaffected, firefox26 unaffected, firefox27 verified, firefox28 verified, firefox-esr17 unaffected, firefox-esr24 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The keybindings for undo and redo work just fine, but if you press the menu items they act unpredictably (usually not at all). This likely has to do with the switch to CodeMirror.
(Reporter)

Updated

5 years ago
Priority: -- → P3
(Reporter)

Updated

5 years ago
Priority: P3 → P1
(Assignee)

Comment 1

5 years ago
It seems like Editor's custom controller doesn't get called through the goDoCommand. I'm not sure why yet. I can see supportsCommand being called and returning true but that's about it.
Assignee: nobody → anton
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Blocks: 929766
(Assignee)

Comment 2

5 years ago
Created attachment 827100 [details] [diff] [review]
WIP 1

This patch attaches controller to the hidden text area. It also removes cmd_cut and cmd_paste from the controller since we don't really need them there *and* they trigger an infinite recursion error which was hidden because of this very bug. :)
Attachment #827100 - Flags: review?(bbenvie)
(Assignee)

Comment 3

5 years ago
We will need to uplift this patch to Aurora once its reviewed and in Nightly.
status-firefox25: --- → unaffected
status-firefox26: --- → unaffected
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox-esr17: --- → unaffected
status-firefox-esr24: --- → unaffected
(Reporter)

Comment 4

5 years ago
Comment on attachment 827100 [details] [diff] [review]
WIP 1

Review of attachment 827100 [details] [diff] [review]:
-----------------------------------------------------------------

This all looks straightforward, although I might not be qualified to pass judgement on editor stuff since I haven't worked with it. I suppose you're the main person who's worked on it, besides Optimizer. LGTM though!
Attachment #827100 - Flags: review?(bbenvie) → review+
(Assignee)

Comment 6

5 years ago
Comment on attachment 827100 [details] [diff] [review]
WIP 1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 912260
User impact if declined: undo/redo buttons won't work in Scratchpad
Testing completed (on m-c, etc.): fx-team, m-c after fx-team to m-c merge, local
Risk to taking this patch (and alternatives if risky): Low risk. Code didn't change much.
String or IDL/UUID changes made by this patch: N/A
Attachment #827100 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/99497e0ef81e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28

Updated

5 years ago
Attachment #827100 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/9b4b4c1b6dfe
status-firefox27: affected → fixed
status-firefox28: affected → fixed

Updated

5 years ago
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

Verified as fixed on latest Aurora (buildID: 20131107004005) and latest Nightly (buildID: 20131107030200).
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
status-firefox28: fixed → verified
Keywords: verifyme
Blocks: 971907
No longer blocks: 971907

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.