Closed Bug 933080 Opened 9 years ago Closed 8 years ago

Add b2g-inbound, fx-team, and mozilla-central to regression archive

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Assigned: nthomas)

References

Details

... so that we can resolve regressions in merges from b2g-inbound and fx-team, and have sub-nightly resolution on m-c too.

We're going to use the same bucket on S3, so this is mostly changes to how we sync builds up to Amazon; the webapp should be fine as is.  There's talk of using a better domain than inbound-archive.pub.build.mozilla.org, possibly just archive.pub.build.mozilla.org. Easily done in DNS plus blogging.
I've made a start on uploading the 30 days of builds we have on ftp.m.o to S3, oldest first.
fx-team and b2g-inbound are up, working on mozilla-central.
mozilla-central is up, and the cron job to keep them up to date includes the three new branches. Still to do - finalize new domain name, set up DNS, blog.
Will this include b2g-desktop builds (and if not can we include them for all platforms)
Flags: needinfo?(nthomas)
At the moment it doesn't, because I'm not uploading the dirs like
 http://ftp.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/mozilla-inbound-macosx64_gecko/
(nothing in .../b2g/... in fact). Before I add them, what is the use case for keeping them ? Specifically, can these builds be used to detect regressions that we can't get with other builds ? Are both the _gecko and _gecko_localiser directories needed ?
Flags: needinfo?(nthomas)
> can these builds be used to detect regressions that we can't get with other builds ?

Yes absolutely- b2g is very different then firefox in the context of FirefoxOS particularly once we roll out OOP b2g-desktop builds.

> Are both the _gecko and _gecko_localiser directories needed ?

Just _gecko I honestly don't know what the localizer ones are used for.

Aside from bisecting and storage I would also like to get read only access to the s3 api for various automation usages http://docs.aws.amazon.com/AmazonS3/latest/API/RESTBucketOps.html
QA Contact: john+bugzilla
This is complete for desktop + mobile, as are syncing all branches there. If we would still like to do b2g lets file a new bug for b2g and set it to bug block 765258.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.