Closed Bug 933206 Opened 8 years ago Closed 8 years ago

[Status Bar] Update Battery Icons

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v1.1hd ?)

RESOLVED FIXED
Tracking Status
b2g-v1.1hd --- ?

People

(Reporter: epang, Assigned: pla)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, jian)

Attachments

(8 files, 2 obsolete files)

Update to new styling of battery icons.  Specs to follow..
Hi Pavel, 

I'll be sending you updated battery icons to replace the current ones. I just have a few questions:

1. The new battery icons are wider than the current ones by 4px (21px to 25px). Will this be an issue? 

2. Because of the wider size, the battery icons needed to be moved over to fit within the sprite sheet evenly. Is this okay? The slicing will need to be adjusted for the battery icons only.  

3. Can you please send me the latest version of the status bar sprite that is in the build? Ideally if it's a transparent png we don't have to replace the background colour. 

Once you send over the latest status bar sprite, I can replace the battery icons in it to ensure that none of the other icons are affected.

Thanks for your help!
Flags: needinfo?(pivanov)
Attached file Statusbar_Sprite.zip (obsolete) —
Hi Pavel, 

Attached is the updated status bar sprite sheet for @1 and @1.5 scale. We aren't supporting @2 scale. Let me know if you need anything else. 

Thanks!
Attached image small pixels problem
Hey Amy,
I think that we have some small pixels problems here ... see the the lightning icons.
Flags: needinfo?(amylee.design)
Attached image REVISED_statusbar_icons_sprite_1.2.png (obsolete) —
Hi Pavel, 

I've attached a revised png file of the icons. The lightening bolt should be aligned now. I checked the @1.5 version and it looked okay. Let me know if you need anything else.
Flags: needinfo?(amylee.design)
Comment on attachment 829723 [details] [review]
patch for Gaia/master

Looks good to me but I’m not sure I’m qualified to land patches in the System app. Tim, can you have a quick look please?
Attachment #829723 - Flags: review?(timdream)
Attachment #829723 - Flags: review?(kaze)
Attachment #829723 - Flags: review+
Comment on attachment 829723 [details] [review]
patch for Gaia/master

It's fine if you have looked it.
Attachment #829723 - Flags: review?(timdream) → feedback+
master: https://github.com/mozilla-b2g/gaia/commit/5066947b583d0a6700b521c21c23f8f00b5c05ab
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
thanks everyone for getting this done so quickly!
Attached image Battery Icon
Um..  Isn't that kind of.. not okay ? :s
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #11)
> Created attachment 831122 [details]
> Battery Icon
> 
> Um..  Isn't that kind of.. not okay ? :s

Yeah I saw that too on dppx=1.5 phones.

revert master: 0700708f972836dc5bce24470da716a124fa003b

Peter, could you fix the @1.5 file?
Status: RESOLVED → REOPENED
Flags: needinfo?(pla)
Resolution: FIXED → ---
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #12)
> (In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #11)
> > Created attachment 831122 [details]
> > Battery Icon
> > 
> > Um..  Isn't that kind of.. not okay ? :s
> 
> Yeah I saw that too on dppx=1.5 phones.
> 
> revert master: 0700708f972836dc5bce24470da716a124fa003b
> 
> Peter, could you fix the @1.5 file?

Redirecting to Amy/Pavel, can you please take a look at this? Looks like the icons on the sprite aren't positioned correctly. Thanks!
Flags: needinfo?(pivanov)
Flags: needinfo?(amylee.design)
Hey guys, 

Since the battery icon was scaled to 1.5x, the width of the battery became 37.5px and we can't have half pixels so I needed to either round up or down by .5 pixels. I had rounded the pixel up and so all the icons are wider by .5 pixel. The coordinates will need to be adjusted on Pavel's end for the @1.5 version. I've attached a guide for reference. The width should be 38px. Let me know if you have any questions.

Cheers,
Amy
Flags: needinfo?(amylee.design)
Attached file patch for Gaia/master
Hey Ahmed,
can you check this patch? I don't have HD device right now

Thanks in advance :)
Flags: needinfo?(pivanov) → needinfo?(nefzaoui.ahmed)
Attached image battery1dot5.png
Regardless the fact that icons@1.5x.png is in Gallery in this PR ( no worries :-) )
This is what I'm getting..
Flags: needinfo?(nefzaoui.ahmed)
I think it's because of the extra ~0.06 added to the icon's size every time we advance to the next sprite; because it's not an absolute 2.6rem.. So reaching the data-level="90" means we added about half of the icon next to it.. :-)
huh ... mistake ... I updated the PR :) can you check it again pls :)
I'm confused.. Should I just try the updated width (2.5rem) and the image containing new icons.. Or the updated width and the classic 1.5 one as it appears now in the PR..
?
Try the last one ... should work :)
Tested it last night but still.. Sent you an email about that
Summary: [Status Bar] Update Battery Icons → [Status Bar] Update Battery Icons - Airplane Mode, Messages, Geolocation
Summary: [Status Bar] Update Battery Icons - Airplane Mode, Messages, Geolocation → [Status Bar] Update Battery Icons
Comment on attachment 831596 [details] [review]
patch for Gaia/master

Hey Ahmed,
I just have a chance to test the patch on SD and HD device and it looks good. Can you confirm?
Attachment #831596 - Flags: feedback?(nefzaoui.ahmed)
Confirmed.
Working like a charm :)
Attached image Screenshot after patch
Flags: needinfo?(pla)
Comment on attachment 831596 [details] [review]
patch for Gaia/master

Hey Kaze,
I fixed the problem and now works as expected :)
Attachment #831596 - Flags: review?(kaze)
Attached file StatusBar_Icons.zip
Hi Pavel, 

Here are the updated sprites (with the new icons). Thanks!
Attachment #828762 - Attachment is obsolete: true
Attachment #829298 - Attachment is obsolete: true
Thanks Amy,
but I will use them on Bug 939272 when we land this one :) Thanks for the fast replay :)
Attachment #831596 - Flags: review?(kaze) → review?(21)
Thanks :)

Landed on master:
https://github.com/mozilla-b2g/gaia/commit/3b6e3abf60b5156df2704c50f5f6bae37d92975a
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Comment on attachment 831596 [details] [review]
patch for Gaia/master

Clearing an old feedback request.
Attachment #831596 - Flags: feedback?(nefzaoui.ahmed)
You need to log in before you can comment on or make changes to this bug.