after SM upgrade the mailto procedure does not work, although the sea monkey is default email client

RESOLVED DUPLICATE of bug 913493

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 913493
4 years ago
4 years ago

People

(Reporter: zetka, Unassigned)

Tracking

SeaMonkey 2.22 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0 SeaMonkey/2.22 (Beta/Release)
Build ID: 20131023190953

Steps to reproduce:

Having updated to SM 2.22 (beta). Controlled the Setting in XP controll pannel for email client, default setting is SM. When I try to send a file as attachment from other application (Irfanview, MS Word, Adobe Reader etc), errorneously the Browser window opens, nor the email client window. After a while an error appears with non specified error.


Actual results:

the attachment data are not sent correctly to email client, email editor does not open. it is interesting, that when I try to open the SM preferences/Mail&Newsgroups, the buttons under "Make SeaMonkey the default appication for" are all grey, I was not able to change it.


Expected results:

after sending file as attachment from other programs, the mail window with this attachment should be opened and after that the mail should be sent.
(Reporter)

Comment 1

4 years ago
Maybe a small hint -when I start seamonkey.exe mailto from command line, it does not start with email editing, but it opens the browser window, with address "http://mailto/".
(In reply to zetka from comment #1)
> Maybe a small hint -when I start seamonkey.exe mailto from command line, it
> does not start with email editing, but it opens the browser window, with
> address "http://mailto/".

To open the mail client, it's
    seamonkey -mail
To open a specific mailto address, it's (IIUC)
    seamonkey mailto:somebody@example.net
The colon after "mailto" is essential.

For a list of all command-line options, see
    seamonkey -h |more
On Windows, without |more (or >file etc.) there won't be any output. On other platforms, |more (or |less etc.) doesn't hurt.

Comment 3

4 years ago
After upgrade to v2.22 I have this issue too, downgrading to 2.21 things works fine again. Thus v2.22 is somehow broken, doing SM unusable for mailing from any windows (SMAPI utilizing) applications.

IMO this is _very_ significant problem and I call for increasing importance for this bug. Similar, basic program functionality affecting bugs, equates SM/TB to position of toy for several enthusiasts, not as tool for serious work.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913493
(Reporter)

Comment 5

4 years ago
(In reply to Franta Hanzlik from comment #3)
> After upgrade to v2.22 I have this issue too, downgrading to 2.21 things
> works fine again. Thus v2.22 is somehow broken, doing SM unusable for
> mailing from any windows (SMAPI utilizing) applications.
> 
> IMO this is _very_ significant problem and I call for increasing importance
> for this bug. Similar, basic program functionality affecting bugs, equates
> SM/TB to position of toy for several enthusiasts, not as tool for serious
> work.

I agree with Franta, such as important error seems to be clasified as CRITICAL and resolved ASAP.

zetka
(Reporter)

Updated

4 years ago
Severity: normal → major
You need to log in before you can comment on or make changes to this bug.