Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Firefox for Android doesn't fall back to es-ES when device language set as any other Spanish locale code

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
10 months ago

People

(Reporter: lcamacho, Assigned: gueroJeff)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

244.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

4 years ago
Steps to reproduce:
1. Set android device language to Spanish (United States).
2. Open FF, it shows English interface.

If you go to Settings->Mozilla->About Firefox it shows spanish translated page.

Expected result:
FF should show spanish interface.
(Assignee)

Comment 1

4 years ago
This appears to be a language fallback issue. Since we only ship one Spanish language code (es-ES) and some carriers (like Verizon in the US) will only enable what they feel to be the most relevant language codes (en-US), US-based users cannot switch their default language preferences for Firefox based on the Android system language settings. Additional use case/rationale for getting bug 917480 done as quickly as possible. :-)

Updated

4 years ago
Summary: Firefox for Android doesn't show spanish interface → Firefox for Android doesn't fall back to es-ES when device language set as Español (Estados Unidos)
(Assignee)

Comment 2

4 years ago
I've received confirmation that this isn't unique to Español (Estados Unidos) but any locale that is not es-ES.
Summary: Firefox for Android doesn't fall back to es-ES when device language set as Español (Estados Unidos) → Firefox for Android doesn't fall back to es-ES when device language set as any other Spanish locale code
(Assignee)

Comment 3

4 years ago
Adding to steps to reproduce for users outside of Spain:
With Firefox for Android closed:
1. Set android device language to Spanish (YOUR_COUNTRY).
2. Restart device.
3. Open FF, it shows English UI.
4. Go to Settings->Mozilla->About Firefox to confirm the page is in Spanish, with the app UI in English.

Results:
Browser UI will be in English, but any in-product pages will be translated into Spanish.

Expected result:
Fennec app UI and web parts should be in Spanish.

Comment 4

4 years ago
I've tested step to step, I confirm that the bug exists.
> https://www.dropbox.com/s/b8sk9qxh9458dr7/android_lang_es-MX.jpg
> https://www.dropbox.com/s/ih8uj7nit0731jr/firefoxos_about.jpg

Comment 5

4 years ago
I think we should probably package es-ES and both es-ES and es. Similar for other region-affected locale codes, but for pt-* and zh-*
(Assignee)

Comment 6

4 years ago
(In reply to Axel Hecht [:Pike] [pto: November 4] from comment #5)
> I think we should probably package es-ES and both es-ES and es. Similar for
> other region-affected locale codes, but for pt-* and zh-*

Why not for pt-* and zh-*? Certainly it wouldn't require much to complete es-MX and have that ship for es-MX and es-US, allowing for both a LATAM and a continental variant.

I also question if French is affected by this bug in Canada and if it makes sense to stand up a fr-CA and fr-FR.

Comment 7

4 years ago
Not for pt-* and zh-*, because we don't know which to fall back to. Or I don't for pt-*, and I think for zh-* it's different per region.

French isn't affected, because our locale code is just 'fr', and not fr-FR.

It's really just nb-NO and sv-SE that might benefit from this. en-GB shouldn't be packed as 'en', not sure if it matters for ga-IE.

Updated

4 years ago
tracking-fennec: --- → ?
Assignee: nobody → l10n
tracking-fennec: ? → 28+

Comment 8

4 years ago
I don't have time to work on this, sorry.
Assignee: l10n → nobody
(Assignee)

Comment 9

4 years ago
(In reply to Axel Hecht [:Pike] from comment #8)
> I don't have time to work on this, sorry.

I can look into it next week and use you as point of contact. Do you have time for that?
Assignee: nobody → l10n

Comment 10

4 years ago
Mark, just assigning bugs to me is not going to work, in particular if I already said that I don't have time to work on this.
Assignee: l10n → nobody
Richard - Can you and Jeff look into this?
Assignee: nobody → rnewman
My sledgehammer solution for this is to rename/package es-MX as es.

Mexico has more Spanish speakers than any other country, and es-US and other American dialects should be (in my experience) closer to to es-MX than es-ES.

es-ES is a minority dialect of Spanish, and asserting that it's the default would be like asserting the en-GB should be the default English dialect. (Both are minority, originating, and "international standard" languages with relatively few speakers.)


The ideal solution is to allow for locales to be chained, rather than only being deltas against en-US, and then we can have es, es-LatAm, es-{MX,…}, es-ES, etc.

Is that something we can do? If so, we could define the whole tree of Spanish locales off a clone of es-MX=>es, and improve them over time.

Comment 13

4 years ago
I'd not rely on the es-MX community to drive our fallback Spanish, I think that mozilla hispano driving this effort within the es-ES repo is more promising.
(In reply to Axel Hecht [:Pike] from comment #13)
> I'd not rely on the es-MX community to drive our fallback Spanish, I think
> that mozilla hispano driving this effort within the es-ES repo is more
> promising.

Can you unpack that statement for me?

Are you disagreeing that Latin American Spanish should be the fallback, or are you disagreeing with the mechanism for establishing it?

If you'd said "within a new es repo", rather than "within the es-ES repo", I would be a lot less confused than I am right now.

Comment 15

4 years ago
This is less about locale codes but the community behind those repositories. Jeff has more details, but for the "global Spanish" on Firefox OS, we're relying on folks like Willy and Inma.

Right now, the only Spanish variant in maemo-locales is es-ES, and I think we should get that working first.

If at some point we have a local variant that we deem to be more appropriate as global fallback, we should go for that.

Technically, use es-ES as es and es-ES.
Then add other Spanish variants to maemo-locales.
Evaluate if there are better offers for 'es' among what we have in maemo-locales.
OK, I'm gonna assign this to Jeff. Jeff, if there's anything I can do to help, let me know!
Assignee: rnewman → jbeatty
Status: NEW → ASSIGNED
Hardware: ARM → All

Updated

4 years ago
tracking-fennec: 28+ → +
(Assignee)

Comment 17

4 years ago
Please remove version tracking for this. There are community dynamics at play with this bug that I'm working through.

Updated

4 years ago
tracking-fennec: + → ---

Updated

3 years ago
Duplicate of this bug: 809488

Comment 19

3 years ago
Hello team!

My name is Sabina & I am a Social Media Manager for Mozilla over here at Nobox.
We have been getting a lot of tweets from people regarding this bug & asking when it is going to be fixed. Is there any answer I can give these folks? Thanks!
There is no timeline or specific tracking for this bug.
(Assignee)

Comment 21

3 years ago
(In reply to Sabina from comment #19)
> Hello team!
> 
> My name is Sabina & I am a Social Media Manager for Mozilla over here at
> Nobox.
> We have been getting a lot of tweets from people regarding this bug & asking
> when it is going to be fixed. Is there any answer I can give these folks?
> Thanks!

Hi Sabina, is this a trending topic? Where could I find these tweets?

Comment 22

3 years ago
Hi Jeff, tweets have been coming in through our @Firefox_es account. About 4 different users have tweeted us about this bug asking what is the status and when is it going to be fixed. I added a doc where you can see the tweets, they are in Spanish. Any other doubts let me know. Thanks!

Comment 23

3 years ago
Created attachment 8406863 [details]
Tweets about Firefox Android ES.docx
Right now the best chance of this being partially fixed would be bug 917480. Which will allow the user to change the UI language.
Jeff (and Axel), can you teach me what I'd need to do to get the non-community parts of this moving? I'm happy to do legwork, I just need to know which steps to take.
Flags: needinfo?(l10n)

Comment 26

3 years ago
I'm not sure there's much legwork that doesn't affect communities, so forwarding this to Jeff.
Flags: needinfo?(l10n) → needinfo?(jbeatty)
(Assignee)

Comment 27

3 years ago
Both Axel and Kevin are right, a partial fix would be bug 917480, but a full fix requires community buy-in. Fennec owners from the Spanish communities have been presented with several options to resolve this. Hopefully there's an agreement on the fix soon.
Flags: needinfo?(jbeatty)

Comment 28

3 years ago
Thanks for picking this up again guys! 
We keep getting requests from the Spanish speaking communities in Latin America about this issue through Twitter (@Firefox_ES) and they would like this to be resolved as soon as possible because a lot of people in Latin America might choose not to use Firefox for Android because of this. There is even a video on YouTube discussing this bug: http://www.youtube.com/watch?v=uKuJp3Fc71Y&feature=youtu.be
(Assignee)

Comment 29

3 years ago
(In reply to Sabina from comment #28)
> Thanks for picking this up again guys! 
> We keep getting requests from the Spanish speaking communities in Latin
> America about this issue through Twitter (@Firefox_ES) and they would like
> this to be resolved as soon as possible because a lot of people in Latin
> America might choose not to use Firefox for Android because of this. There
> is even a video on YouTube discussing this bug:
> http://www.youtube.com/watch?v=uKuJp3Fc71Y&feature=youtu.be

There is a plan tentatively agreed upon by the community. Hoping to provide both a temporary and long-term fix shortly.

Comment 30

3 years ago
Hi, in Mozilla-hispano we've noticed this time ago in the awesome army, in our forum and in the reviews of Firefox for android in the play store, many people are complaining about this. Do you know if there are someone working on fix this?
(Assignee)

Comment 31

3 years ago
(In reply to fnk from comment #30)
> Hi, in Mozilla-hispano we've noticed this time ago in the awesome army, in
> our forum and in the reviews of Firefox for android in the play store, many
> people are complaining about this. Do you know if there are someone working
> on fix this?

Yes, it's being worked on now. Currently coordinating with all es l10n teams.
In Bug 1101527, I noticed that we currently do a fallback for zh-HK:

        if (locale.toString().equalsIgnoreCase("zh_hk")) {
            locale = Locale.TRADITIONAL_CHINESE;
            Locale.setDefault(locale);
        }

If we elect to keep this code (moving it into the locale manager), should we also take this opportunity to apply fallbacks for es-*?
(Assignee)

Comment 33

10 months ago
Resolving as this bug was fixed with the introduction of the language switcher UI piece in the Firefox for Android settings. Users can now select their Firefox language through that UI rather than relying on the OS to do the right thing.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.