Email address should not allow "<" or ">"

VERIFIED DUPLICATE of bug 87701

Status

()

Bugzilla
Bugzilla-General
VERIFIED DUPLICATE of bug 87701
17 years ago
4 years ago

People

(Reporter: Christopher Aillon (sabbatical, not receiving bugmail), Assigned: justdave)

Tracking

Details

(URL)

No reporter is listed, and changing bugs will include a , , where their e-mail
should be.  Not sure of the cause of this one but IMO users should not be able
to file a bug if no e-mail address is given.

Here is the output I got when changing bug 93373.  Notice the , , after dveditz
on the changed bug and after tpreston on the original duped bug.

Changes to bug 93373 submitted
Email sent to: sgehani@netscape.com, dveditz@netscape.com, ,
sairuh@netscape.com, tpreston@netscape.com
Excluding: caillon@returnzero.com
If you wish to tweak the kinds of mail Bugzilla sends you, you can change your
preferences
Back To BUG# 93373
Duplicate notation added to bug 86723
Email sent to: hyatt@netscape.com, brendan@mozilla.org, jrgm@netscape.com,
blake@netscape.com, smallen@ucdavis.edu, cmeyer@gatan.com, sairuh@netscape.com,
tpreston@netscape.com, , Junk_HbJ@hotmail.com, abonnema@cistron.nl,
attinasi@netscape.com, bugzilla@uxp.de, chipc@netscape.com,
doctor__j@hotmail.com, fjleon@iamnet.com, janc@netscape.com, jesser@oeone.com,
mozilla@propagandafactory.com, neil.marshall@sympatico.ca, pchen@netscape.com,
pinkerton@netscape.com, sfraser@netscape.com, bugmail@spam.hixie.ch,
jpm@netscape.com
Excluding: mozilla@propagandafactor
If you wish to tweak the kinds of mail Bugzilla sends you, you can change your
preferences

Comment 1

17 years ago
seems that the person used <myemail@address.com> as his email address, so the
browser sees this a a tag and doesn't display it. I think the fix for this would
be to escape those characters (and maybe others)? Or is this considered a feature?
Thanks Basic for finding that cause of that.  Changing summary to reflect what's
going on.  Also, I'm going to file a bug on a full name with a space like you
demonstrated just now :-P
Summary: Reporter email/name blank → Email address should not allow "<" or ">"
This is fixed, however, bugzilla.mozilla.org hasn't picked up the changes yet.  
They'll get it next time they update.


*** This bug has been marked as a duplicate of 87701 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.