[OTA][Buri] Update fails from 1.1 to 1.2 due to system remount issue

RESOLVED DUPLICATE of bug 907444

Status

RESOLVED DUPLICATE of bug 907444
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

1. download and update to 20131031041204 build of 1.1 buri/hamachi
2. use script from : https://github.com/Mozilla-TWQA/B2G-flash-tool/pull/55 with parameters : ./change_OTA_channel_pref.sh -v 1.2.0 -d hamachi
3. run the update

Expected: updated to 1.2
Actual: update fails:
Note:

11-01 14:54:12.809: I/GeckoUpdater(718): Progress [ ================================================== ]
11-01 14:54:12.809: I/GeckoUpdater(718): Finished applying update
11-01 14:54:12.959: I/GonkAutoMounter(718): Mounted /system partition as read-only
11-01 14:54:12.979: I/Gecko(460): *** AUS:SVC readStatusFile - status: failed: 7, path: /data/local/updates/0/update.status
11-01 14:54:12.979: I/Gecko(460): UpdatePrompt: Update error, state: failed, errorCode: 7
11-01 14:54:12.999: I/Gecko(460): UpdatePrompt: Setting gecko.updateStatus: Install Pending
11-01 14:54:13.039: I/Gecko(460): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 7
blocking-b2g: --- → koi+
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
blocking-b2g: koi+ → koi?
1.1 buri build : 
Gaia   39b0203fa9809052c8c4d4332fef03bbaf0426fc
SourceStamp 31fa87bfba88
BuildID 20131031041204
Version 18.0
Summary: [OTA] Update fails from 1.1 to 1.2 due to system remount issue → [OTA][Buri] Update fails from 1.1 to 1.2 due to system remount issue

Updated

5 years ago
Blocks: 907444
Error code 7 typically means that it ran out of space while trying to apply the update.

To know for sure, you need to open up an adb shell and do:

adb shell df /system

repeatedly while its applying the update and see if the free space goes down to or really close to zero.
I should note, that once it fails, it removes all of the backup files that it created, so the free space will suddenly jump to a bunch of Mb after it fails (this is why you need to do it repeatedly while the update is being applied)
If it's an out of space issue, then it's the same problem already covered in bug 907444. Oh well, I guess that confirms we still have the same problem.
No longer blocks: 907444
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907444
You need to log in before you can comment on or make changes to this bug.