If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Memory leak after closing every new composition window (modern theme)

VERIFIED DUPLICATE of bug 87040

Status

MailNews Core
Backend
--
major
VERIFIED DUPLICATE of bug 87040
16 years ago
9 years ago

People

(Reporter: Dimitrios, Assigned: dbaron)

Tracking

({mlk})

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
build 2001080203, Win95
Mozilla memory usage monitoring using SpyGuru:
a. After opening a new window (or use reply or forward) for the first time and
then closing it, memory usage is increased by about 3.8MB.
b. By subsequently opening and closing more composition windows, memory usage is
also increased (270-330Kb for every window).

Memory is returned to the system, after shutting down Mozilla (can I call it
leak then?). It is NOT returned to the system after closing Mail&News in turbo
mode. This makes turbo made unusable after prolonged operation, particularly in
memory constraint systems (64MB ram).
(Reporter)

Updated

16 years ago
Severity: normal → major
Keywords: mlk
This has been fixed very recently but not until after the build you're running
was created.  The patch didn't land until a few hours ago.  See bug 87040
Assignee: ducarroz → dbaron
Component: Composition → Mail Back End
QA Contact: sheelar → esther

*** This bug has been marked as a duplicate of 87040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Yes, it's a dupe of 87040 and the fix really works! Memory does not increase
anymore.

Comment 4

16 years ago
Makring verified as duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.