Closed Bug 933990 Opened 7 years ago Closed 7 years ago

apzc ignores double taps while a page is still loading

Categories

(Core :: Layout, defect, P3)

x86_64
Windows 8
defect

Tracking

()

RESOLVED DUPLICATE of bug 942189

People

(Reporter: ally, Unassigned)

References

Details

(Whiteboard: [beta28][layout])

I've been seeing this on & off since starting to work on dttz, but a couple of weeks ago, it started to happen every time. The first double tap is always ignored, and the second triggers the double tap message, usually I see
MetroWidget::ApzContentIgnoringTouch appear in console after the first doubletap.
Blocks: 941324
With the patches in bug 941324 applied, I'm seeing something that I think is the same as this bug.  Any double-taps while a page is still loading are ignored, but if I wait for the page to finish loading then double-tap works (even the first time).

Possibly the same underlying issues as bug 942189.
Depends on: 942189
Summary: apzc always ignores first double tap → apzc ignores double taps while a page is still loading
Blocks: metro-apzc
Whiteboard: [triage]
Whiteboard: [triage] → [block28]
Whiteboard: [block28] → [beta28]
Component: Pan and Zoom → Layout
Product: Firefox for Metro → Core
Whiteboard: [beta28] → [beta28][layout]
Blocks: metrov1backlog, metrov1omtc&apzc
No longer blocks: metro-apzc
Per discussions between marcom and milan, we're requesting tracking on the remaining "big issues" related to apzc for metrofx, which is riding the 28 train. We expect these will get fixed during the long aurora train ride.

This is likely a dupe of bug 942189. We need to confirm once that bug gets fixed.
Priority: -- → P3
Marking this as duplicate now; from what I've seen in the debugger this is the exact same issue as bug 942189.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942189
No longer blocks: metrov1backlog
You need to log in before you can comment on or make changes to this bug.