Closed Bug 934101 Opened 9 years ago Closed 9 years ago

Intermittent failure for marionette-js test: NoSuchElement: (7) Unable to locate element: .card-compose .cmp-back-btn

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 925961

People

(Reporter: julienw, Unassigned)

Details

1) go to local drafts page should show the correct email address in a item of mail list:

NoSuchElement: (7) Unable to locate element: .card-compose .cmp-back-btn

Remote Stack:

<none>

at Error.MarionetteError (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)

at Object.Client._handleCallback (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:472:19)

at /home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:506:21

at TcpSync.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:94:10)

at Object.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:453:36)

at Object.Client._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:499:19)

at Object._findElement (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1281:19)

at Object.findElement (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1330:32)

at Object.MarionetteHelper.waitForElement (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-helper/index.js:126:19)

at Object.Email._waitForElementNoTransition (/home/travis/build/mozilla-b2g/gaia/apps/email/test/marionette/lib/email.js:421:31)

at Object.Email.saveLocalDrafts (/home/travis/build/mozilla-b2g/gaia/apps/email/test/marionette/lib/email.js:233:10)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/email/test/marionette/local_drafts_test.js:40:9)

at Test.Runnable.run (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:211:32)

at Runner.runTest (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:355:10)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:401:12

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:281:14)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:290:7

at next (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:234:23)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runner.js:253:7

at done (/home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:185:5)

at /home/travis/build/mozilla-b2g/gaia/node_modules/mocha/lib/runnable.js:197:9

at /home/travis/build/mozilla-b2g/gaia/apps/email/test/marionette/lib/servers/fakeimap.js:73:7

at /home/travis/build/mozilla-b2g/gaia/node_modules/mail-fakeservers/lib/control_server.js:58:7

at IncomingMessage.<anonymous> (/home/travis/build/mozilla-b2g/gaia/node_modules/mail-fakeservers/lib/control_request.js:30:7)

at IncomingMessage.g (events.js:175:14)

at IncomingMessage.EventEmitter.emit (events.js:117:20)

at _stream_readable.js:910:16

at process._tickCallback (node.js:415:13)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925961
You need to log in before you can comment on or make changes to this bug.