Closed Bug 934105 Opened 9 years ago Closed 7 years ago

macuser.gr doesn't show mobile design on Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alefteris, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-gr][serversniff][sitewait])

Site: http://www.macuser.gr
macuser.gr doesn't show mobile design on Firefox OS

:: Steps To Reproduce

1. Open Firefox OS browser
2. Type macuser.gr in Firefox OS browser address bar

:: Expected Result

Get mobile design version of http://www.macuser.gr. When viewing the web site on Firefox for Android or iOS Safari we get the mobile version.

:: Actual Result

We receive the desktop site of http://www.macuser.gr

This issue looks similar to what is happening with techgear.gr (https://bugzilla.mozilla.org/show_bug.cgi?id=932007)

:: Additional Information

Software Version: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
Device Information: Keon
Whiteboard: [country-gr]
I send a message using the contact form at http://24media.gr/el/contact/
Yep, looks like the same issue. They just need to update their theme and it should detect FxOS as a mobile UA.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr] → [country-gr][serversniff][sitewait]
Send another message using the contact form at http://www.macuser.gr/contact-macuser/
Trying to contact a human on twitter.
http://twitter.com/MozWebCompat/status/496200790638604288
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
These are part of the sites made by DarkPony which exhibit the same issue. So that should be easy to solve once we got a contatc. Contacted someone there.
Sent again an email yesterday. Got an answer. 
Explained the issues and how to test.
See Also: → 932007
So the person in contact replied nicely.

> It seems that W3 Cache plugin we use on both website messes things up.
> https://www.w3-edge.com/products/w3-total-cache/

I will try to see if we can do anything with w3cacheplugin
Reminder: This is about Bug 932007 too. The person confirmed that they used the same type of setup.
I created https://webcompat.com/issues/777 about W3C Total Cache issues.
Congrats - seems fine now :)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.