When upgrading a profile to Australis there should be a warning or information about customizations

RESOLVED DUPLICATE of bug 939305

Status

()

defect
RESOLVED DUPLICATE of bug 939305
6 years ago
6 years ago

People

(Reporter: Robert.Zenz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112903

Steps to reproduce:

At the moment upgrading to Australis does simply change the current layout of the profile without any warning or notification. This is especially bad (when Australis is released) if you consider auto-updates or not directly user invoked updates (via apt-get f.e.) in combination with the rapid release cycle as it leaves the user without any notification of what just happened.


Actual results:

Customizations are silently undone and can not be restored (f.e. having the tabs on the bottom or having the navigation box in the menu bar).


Expected results:

The user should be notified why this just happened and possible solutions could be presented.
We are working on a first-run experience / UI Tour in bug 862998 and dependencies which may help with some of this.
Blocks: fx-UITour
Component: Untriaged → General
OS: Linux → All
Hardware: x86 → All
Version: 28 Branch → unspecified
No longer blocks: fx-UITour
Depends on: fx-UITour
Alex: This seems like a dupe of the thing you're building.
I see there is now a meta bug for that onboarding (aka. first-run) work so I'll dupe this there.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939305
You need to log in before you can comment on or make changes to this bug.