Closed Bug 934126 Opened 8 years ago Closed 4 years ago

itau.com.br tells me to download their app, if I touch this button I got redirected to their mobile page

Categories

(Web Compatibility :: Mobile, defect, P5)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: leonardo.balter, Unassigned)

References

()

Details

(Whiteboard: [mobile-compat-form][country-br][sitewait])

Site: http://itau.com.br
itau.com.br tells me to download their app, if I touch this button I got redirected to their mobile page

:: Steps To Reproduce

1. access itau.com.br on my firefox os browser
2. the first page is only telling me to touch a big button to download their app, otherwise I can scroll to continue on the mobile site.
3. I touched the button (why not?) and got redirected to their mobile site
4. I've got one big button to go to the same mobile site.

PS: itau.com.br redirects me to https://ww70.itau.com.br/M/Institucional/AplicativosItau.aspx?B2A382828ECB3B7085B3F9552696BFFC3DEB707AF1EAF909

:: Expected Result

I made me feel they had an app on the Mozilla Marketplace

:: Actual Result

There is no app, it just gets me to the website.

:: Additional Information

Software Version: Firefox OS 1.1.0.1
Device Information: LG Fireweb D300. Firefox OS 1.1
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0
Whiteboard: [mobile-compat-form] → [mobile-compat-form][country-br]
Confirmed, 

Not sure if this should be marked [serversniff]. But essentially we need to contact them and ask that Firefox OS not be served the app interstitial (unless they want to submit an Open Web App to the market, which would also be cool) because it's confusing and doesn't make sense currently.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form][country-br] → [mobile-compat-form][country-br][contactready]
This problem came up in my conversation with @itau... but I still don't think they understand that I'm asking for a contact. :)

http://twatlr.com/thread/403719750263390209
Mike, should I try reaching out?
Flags: needinfo?(miket)
That would be cool, Adam--but I think we're going to need people with actual Itau accounts for them to pay attention. But trying again doesn't hurt. :)
Mike you're right, its not easy to contact without CPF or having a phone conversation.

Leo: do you mind reaching out for us on this one please?
Flags: needinfo?(miket) → needinfo?(leonardo.balter)
I'm trying again. Last try in December, they gave me a protocol number but not further response. 

I asked them again via Twitter to send the link of this bug to the web site responsible in any of their IT teams. I have an account on Itau, so I'm argumenting with them as a client too.
Flags: needinfo?(leonardo.balter)
Ok that's great, thanks so much!
Whiteboard: [mobile-compat-form][country-br][contactready] → [mobile-compat-form][country-br][sitewait]
I'm sorry to tell that this is a "WONTFIX" ticket :/

I will state here the same answer I gave on "Bug 826353"

---

I've talked to an Itau employee that prefers no to be identified, and his answer (in free translation) was the following:

"we evaluate every browser on every operating system (N versions of linux included), devices and even on TVs, but we need to be sure that our website have full functionality available, so our customers don't get frustrated."

"Firefox OS is such a bet and it's being really well developed, still I cannot guarantee that our website is running on thin platform, so we need to HOMOLOGATE and give its proper attention."

The e-mail was finished by he apologizing himself for not helping effectively, but promising they'll be giving attention to Firefox OS sometime in a near future.
Depends on: 826353
Daniel,
Could the itau employee put us in contact directly with the people in charge at Itau?

Basically the issue is basic, everything that "Firefox Android" can receive will work on "Firefox OS" in terms of rendering. Currently Firefox for Android is receiving the mobile site, it's unfortunate that for a simple UA sniffing, Firefox OS is not receiving the same version. 

Thanks for any help.
Flags: needinfo?(daniel.filho)
I know the issue is simple, I know it is fast and easy to solve and I made sure Itau has completely notion about it, but my contact (which doesn't want to have his name even mentioned) don't even answer e-mails anymore.

Sorry for not being able to help any further with this, Karl :/
Flags: needinfo?(daniel.filho)
Currently after an intermediate screen Chrome Mobile users are redirected to
https://ww70.itau.com.br/M/LoginPF.aspx?BFBC898283FA093792AFFA6406BF8C820A88DDA4C26CF2825DB849913729F531F5A9AF8437703CD8

The site is still working without issues in Firefox OS.
Trying to contact http://twitter.com/MozWebCompat/status/585344964739014656
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.